iPhone sends meeting request from "Unknown Organizer"
Results 1 to 9 of 9

Thread: iPhone sends meeting request from "Unknown Organizer"

  1. #1
    Active Member
    Join Date
    May 2013
    Posts
    11

    iPhone sends meeting request from "Unknown Organizer"

    Hi,

    I've just installed the Zextras suite a few days ago to tryout zxMobile. Almost everything is working really well, except for meeting requests sent from my iPhone.
    When I create an new meeting request and invite another external user (not tested with local users, but I think behaviour is the same), the message is received from "Unknown Organizer".
    When I take a look at the mailbox.log file, an Java exception is logged (see below).
    Also, when I take a look at the raw message, indeed the name is set to "Unknown Organizer" (also see below).

    The most strangest thing however is, when I configure my account on my brand new iPad (which never has an email account configured), the meeting requests are sent from "hugo", which is kind of right, since that's me. However, why doesn't that use my full name / display name as configured in Zimbra? "hugo" is my username.
    I was previously using Zpush as an activesync solution on my iPhone, but I removed that account completely and recreated an account for zxMobile (even multiple times by now).
    On the same phone I have an MS Exchange account configured. When i sent an meeting request from this account, the sender is set to my display name in Exchange and works perfectly.
    Any ideas what can cause these issues?

    It looks like with the Zimbra account, the iPhone is sending the meeting request message, since "Apple Mail" is mentioned in the meeting message. When using the exchange account, it seems that exchange is sending this message, which seems like a better approach.

    I'm using Zimbra 8.0.3 (single server) Ubuntu 10.04 and Zextras 1.8.5.
    If more information is needed, please let me know!

    mailbox.log:

    2013-05-10 22:46:28,881 WARN [hugo@domain.tld Appl<SNIP>] [tid=190;] index - error reading text/calendar mime part
    javax.activation.UnsupportedDataTypeException: no object DCH for MIME type text/calendar

    2013-05-10 22:46:28,882 WARN [hugo@domain.tld Appl<snip>] [tid=190;] ParsedMessage - Unable to parse part=2 filename=meeting.ics content-type=text/calendar message-id=<2130339983.817.1368218788830.JavaMail.root@lbk-gc-mail01.domain.tld>
    com.zimbra.cs.mime.MimeHandlerException: no object DCH for MIME type text/calendar

    2013-05-10 22:46:28,885 WARN [hugo@domain.tld Appl<snip>] [tid=190;] ParsedMessage - Message had analysis errors in 1 parts (Message-Id: <2130339983.817.1368218788830.JavaMail.root@lbk-gc-mail01.domain.tld>, Subject: Test9)
    2013-05-10 22:46:28,885 INFO [hugo@domain.tld Appl<snip>] [tid=190;] mailop - Adding Message: id=175644, Message-ID=<2130339983.817.1368218788830.JavaMail.root@lbk-gc-mail01.domain.tld>, parentId=-1, folderId=5, folderName=Sent.
    2013-05-10 22:46:28,898 INFO [hugo@domain.tld Appl<snip>] [tid=190;] smtp - Sending message to MTA at localhost: Message-ID=<2130339983.817.1368218788830.JavaMail.root@lbk-gc-mail01.domain.tld>

    <full error in attachment due to message size limit mailbox-error-log.txt>

    meeting request contents:
    BEGIN:VCALENDAR
    CALSCALE:GREGORIAN
    METHOD:REQUEST
    PRODID:-//Apple Inc.//iPhone 3.0//EN
    VERSION:2.0
    BEGIN:VTIMEZONE
    TZID:Europe/Amsterdam
    BEGIN:DAYLIGHT
    DTSTART:20130331T020000
    RRULE:FREQ=YEARLY;BYMONTH=3;BYDAY=-1SU
    TZNAME:CEST
    TZOFFSETFROM:+0100
    TZOFFSETTO:+0200
    END:DAYLIGHT
    BEGIN:STANDARD
    DTSTART:20131027T030000
    RRULE:FREQ=YEARLY;BYMONTH=10;BYDAY=-1SU
    TZNAME:CET
    TZOFFSETFROM:+0200
    TZOFFSETTO:+0100
    END:STANDARD
    END:VTIMEZONE
    BEGIN:VEVENT
    ATTENDEE;CN=Hugo Rodenburg;CUTYPE=INDIVIDUAL;PARTSTAT=NEEDS-ACTION;RSVP=TRUE
    :mailto:hugo@external.tld
    CREATED:20130512T075908Z
    DTEND;TZID="Europe/Amsterdam":20130512T110000
    DTSTAMP:20130512T075908Z
    DTSTART;TZID="Europe/Amsterdam":20130512T100000
    LAST-MODIFIED:20130512T075908Z
    ORGANIZER;CN=Unknown Organizer;EMAIL=hugo@domain.tld:MAILTO:hugo@<domai n.tl
    d>
    SEQUENCE:0
    SUMMARY:Test
    TRANSP:OPAQUE
    UID:B527820467CA45158BCA13F397298E5800000000000000 000000000000000000
    X-MICROSOFT-CDO-INTENDEDSTATUS:BUSY
    END:VEVENT
    END:VCALENDAR
    --Apple-Mail-B4147FB9-E580-466A-8B9E-CB1FDDAB2AB7--
    .

  2. #2
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,360
    Hello hrodenburg!

    From a first look I'm positive that this is an item-related issue (no object DCH for MIME type text/calendar)... We just solved a similar issue and the devs are checking this particular case.

    I filed a Bug Report on the ZeXtras Bugzilla and will report back as soon as I have any news from the devs!


    Have a nice day,
    Cine

  3. #3
    Active Member
    Join Date
    May 2013
    Posts
    11
    Hello Cine,

    Thanks for the quick reply (again ) and for filing the bug. I didn't create a bug report because I was not sure whether this is a "real" bug or just some misconfiguration on my server.

    It indeed seems account/phone related. Yesterday evening I was able to test with another user's account on this server who is also using an iPhone. When we sent an meeting request from his phone, it arrives using his "display name" used in Zimbra.
    By the way, we both use iPhone's 4S running ios 6.1.3 (latest).
    A third user on this server using an iPhone (4 not 4s to be precise) is also having the same issues as my account does.

    When I have some time, I will create an new test account on the zimbra server and configure this account on my phone to see how it behaves. I will post an update with the results, and add this to the bug report information.

    Hugo

  4. #4
    CTO ZeXtras Employee d0s0n's Avatar
    Join Date
    Apr 2011
    Posts
    570
    Hi Hugo,

    I haven't analyzed your case but I remeber another problem I experienced with the "My Info" settings, take a look at:
    Code:
    Settings -> Mail,Contacts,Calendars -> My Info (Contacts sections)
    Did you set your contact details?

    I have not had time to check out my problem but it could be like this.

    D0s0n
    ZeXtras Website # ZeXtras Wiki # ZeXtras Store

    Head of ZeXtras System Administrators

  5. #5
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,360
    Good news everyone!

    The devs confirm that the issue is indeed related with the lack of "personal" info. If proper information are not entered in the "My Info" section, appointments will suffer this issue.

    A workaround has been pushed in the production tree and will be available in ZeXtras Suite 1.8.6+ . This workaround will override the default mobile behaviour and populate the "organizer" field when missing.

    Have a nice day,
    Cine

  6. #6
    Active Member
    Join Date
    May 2013
    Posts
    11
    Hello all,

    Good tip about the "my info" settings D0s0n! Indeed there was no contact set. However, selecting my own contact does not resolve this problem. There seems to be no difference with or without this set. Both on my iPhone and iPad this setting was empty. I did set it to my own account on both devices. After that, meeting requests from my iPhone are still from "Unknown Organizer" and from my iPad from "hugo". The correct display name should be "Hugo Rodenburg" as set in Zimbra.

    However, we did found out something strange. When we configure the email address in the activesync mail settings to some address which is not the email address of the account, or an alias, the meeting requests do display the user's full name.
    For instance, I have configured on my Zimbra account: hugo@domain.tld and alias@domain.tld. When I configure my phone to use "hugo" or "alias", the meeting requests arrive on the receipient side as "Unknown Organizer". However, when I set my email address on my phone to something like randomaddress@domain.tld, meeting requests appear to come from my full name (which is correct). Offcourse with the nonexistant email address.
    Perhaps this will help finding the cause.
    We have tested this with 2 different accounts, same behaviour.

    I hope I have some time today to test with an newly created account, just to rule out some possible weird configuration in the existing accounts.

    If any logs or other information is required, please let me know, I'm more than happy to help finding the root cause of this problem. I will try to supply them as quickly as possible.

    Hugo

  7. #7
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,360
    Hello Hugo!

    I would like you to run a small test following this steps in order to verify if the issue might still be appearing because of a bad item interfering with the sync:

    - Delete the Exchenge ActiveSync account from the device.
    - Remove the appropriate entry from both the "Active Sessions" and "Registered Devices" lists in ZeXtras Mobile.
    - Reboot the phone (IIRC this is also needed for the changes in the "My Info" section to kick in).
    - Create the Exchange ActiveSync account WITHOUT selecting to sync the calendars (only mail and contacts).
    - Set the "Mail days to sync" field to 1 day.
    - Let the first sync complete.
    - Enable Calendar synchronization.
    - Try to reproduce the issue. If the issue does not happen again, retry after raising the "Mail days to sync". Retry until you reproduce the issue again or until you reach the "No Limit" setting on the "Mail days to sync" option.


    Thanks a lot for your cooperation!

    Have a nice day,
    Cine

  8. #8
    Active Member
    Join Date
    May 2013
    Posts
    11
    Hello Cine,

    Thank you for your quick reply. I followed your steps exactly as you described.
    It's really strange, but it seems that the first meeting request after configuring arrives as it should be.

    1st request:
    ORGANIZER;CN=Hugo Rodenburg;EMAIL=hugo@linuxbak.nl:MAILTO:hugo@linux bak.nl

    2nd and other requests after that:
    ORGANIZER;CN=Unknown Organizer;EMAIL=hugo@linuxbak.nl:MAILTO:hugo@linux bak.n
    l

    I'm not sure this is because it's the first one, or because of some timing thing that I create the request right after setting up the account.

    When I remove the account, and add it again (even without remove the sessions from Zimbra), I can sent 1 meeting request succesfully. I tried sending to an different external address, but that also fails using the correct sender name.

    On my iPhone I use the "Week calender" app (which is really nice btw). Offcourse to rule this out, I did my tests with the native iPhone calender app. Just to be sure I've just removed the app completely from my phone, no change however.
    On the same phone, I also have an Exchange 2010 account configured. I disabled email,contact,calender,task sync for that account, but also doesn't make any difference.

    Please let me know if I can do anything else.

    Hugo

  9. #9
    Active Member
    Join Date
    May 2013
    Posts
    11
    Hi,

    The changelog of 1.8.6 listed these issued as resolved. After testing I can tell you it indeed resolves my issue! I will do some extra testing with other devices, but it seems to work really well! Thank you for the excellent support and quick fix!
    (I will update the bug report as well).

    Thank you very much!

    Hugo

LinkBacks (?)

  1. 05-28-2013, 07:27 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •