Help on configuring Exchange AutoDiscovery and folder listing problem
Results 1 to 6 of 6
Like Tree1Likes
  • 1 Post By iamcypher

Thread: Help on configuring Exchange AutoDiscovery and folder listing problem

  1. #1
    Member
    Join Date
    May 2012
    Posts
    46

    Help on configuring Exchange AutoDiscovery and folder listing problem

    Hello everyone,

    I'm still trying to convince myself that zextras is the product I need and dispite my efforts I'm still encountering problems all over the place. First of all Exchange Autodiscovery does not work because my zimbra installation is not on the root of the domain but on a subdomain. I run apache to host my root domain, and I've read the Admin Wiki and it says:

    ZeXtras Mobile and Apache proxying

    If your Zimbra server runs on non-standard ports an you are using an http/https proxy to redirect connection requests to Zimbra, note that you must manually specify proxy rules to redirect all traffic arriving at

    1&1 Internet - Home

    to

    http://yourdomain.com:zimbraHTTPport...ver-ActiveSync,

    and all traffic arriving at

    https://yourdomain.com/Microsoft-Server-ActiveSync

    to

    https://yourdomain.com:zimbraHTTPSpo...ver-ActiveSync.


    Mind that the "Microsoft-Server-ActiveSync" part is case sensitive.
    Can you please explain how can I do this in apache?

    Also I have an iPhone with iOS 5.1 which keeps receiving empty directory listings on most of folder (Only sent and trash seems to be working). This problem persisted on all zextras versions I have tried and on multiple zimbra versions too. Is there any diagnostics I can run to see what's going wrong?

    I have lastest version of zextras (1.6.3) and Zimbra (8.0.0 GA UBUNTU FOSS Version).

    Thank You,
    Paul.

  2. #2
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Quote Originally Posted by iamcypher View Post
    Hello everyone,
    First of all Exchange Autodiscovery does not work because my zimbra installation is not on the root of the domain but on a subdomain. I run apache to host my root domain, and I've read the Admin Wiki and it says:

    Can you please explain how can I do this in apache?
    Hello iamcypher.
    The Autodiscovery feature is not yet implemented in ZeXtras Mobile. It will be added along with support for the EAS v12 protocol in the near future.
    In any case, the doc snippet you quote has little to do with this unless you host both Zimbra and another Apache instance on the same server.
    The autodiscovery only requires a dedicated SRV record on your public DNS configuration, and can work with any server name (being it yourdomain.com or mail.yourdomain.com).

    Quote Originally Posted by iamcypher View Post
    Also I have an iPhone with iOS 5.1 which keeps receiving empty directory listings on most of folder (Only sent and trash seems to be working). This problem persisted on all zextras versions I have tried and on multiple zimbra versions too. Is there any diagnostics I can run to see what's going wrong?

    I have lastest version of zextras (1.6.3) and Zimbra (8.0.0 GA UBUNTU FOSS Version).

    Thank You,
    Paul.
    This issue has never been reported before, can you please check if the "Days to sync" setting for your account is set to a proper value?
    If it is, please follow this instructions:
    - Delete the account from your mobile phone and delete the related entry from the "Registered Device" list in the ZeXtras Administration Zimlet - ZxMobile tab.
    - Configure an Account Logger (ZxMobile Troubleshooting - ZeXtras Suite Wiki).
    - Create the account on your mobile phone.
    - Let the sync run for 10-15 minutes and then send me the logfile (via email, community@zextras.com)... I'll take a look and see what's going on...

    Have a nice day,
    Cine
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  3. #3
    Member
    Join Date
    May 2012
    Posts
    46
    Uhm, where is the Days to sync setting located. I can't seem to find it.

  4. #4
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Quote Originally Posted by iamcypher View Post
    Uhm, where is the Days to sync setting located. I can't seem to find it.
    Settings -> Mail, Contacts, Calendar -> Your Account, just under the list of items to sync...
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  5. #5
    Member
    Join Date
    May 2012
    Posts
    46
    Sweet, you are right. I never thinked of it. Removing the limit now I can see all my missing emails.

    Thanks so much!
    d0s0n likes this.

  6. #6
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    You're welcome
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •