Calendar not syncing with CyanogenMod 10 (Stable) and stock calendar app
Results 1 to 7 of 7
Like Tree1Likes
  • 1 Post By Toni Garcia

Thread: Calendar not syncing with CyanogenMod 10 (Stable) and stock calendar app

  1. #1
    Active Member
    Join Date
    Mar 2012
    Posts
    16

    Calendar not syncing with CyanogenMod 10 (Stable) and stock calendar app

    I'm using ZxMobile with CyanogenMod some time ago, with no issues in mail and contacts, but activesync calendar is not shown in the stock calendar app.

    I filled a bug to CyanogenMod, so i think this is a CM issue, but while looking for logs in sync.log i found these lines:

    Code:
    2012-11-14 10:04:01,363 INFO  [ZxMobile Handler Thread] [tid=122021;] sync - ZxMobile Handler: [192.168.250.177] ZxMobile Command Sync on account user@domain from device Android/androidc1453619231
    2012-11-14 10:04:01,364 INFO  [ZxMobile Handler Thread] [tid=122021;] sync - Sync[59224]: Sync on folder path: /Calendar
    2012-11-14 10:04:01,364 INFO  [ZxMobile Handler Thread] [tid=122021;] sync - Sync[59224]: Sync states are not equals: D: 5a36ac78e277495ab01a9f2ce8421613/10/69/1 - S: 5a36ac78e277495ab01a9f2ce8421613/10/69/6 - A: user@domain
    2012-11-14 10:04:01,542 INFO  [ZxMobile Handler Thread] [tid=122022;] sync - ZxMobile Handler: [192.168.250.177] ZxMobile Command Sync on account user@domain from device Android/androidc1453619231
    2012-11-14 10:04:01,542 INFO  [ZxMobile Handler Thread] [tid=122022;] sync - Sync[59225]: Sync on folder path: /Calendar
    2012-11-14 10:04:01,806 INFO  [ZxMobile Handler Thread] [tid=122023;] sync - ZxMobile Handler: [192.168.250.177] ZxMobile Command Sync on account user@domain from device Android/androidc1453619231
    2012-11-14 10:04:01,806 INFO  [ZxMobile Handler Thread] [tid=122023;] sync - Sync[59226]: Sync on folder path: /Calendar
    2012-11-14 10:04:01,806 INFO  [ZxMobile Handler Thread] [tid=122023;] sync - Sync[59226]: Getting items older(or newer) than 14 days for type: 11 on folder: /Calendar
    2012-11-14 10:04:01,824 INFO  [ZxMobile Handler Thread] [tid=122023;] sync - Sync[59226]: Removed items: 0; Changed items: 0
    2012-11-14 10:04:01,825 INFO  [ZxMobile Handler Thread] [tid=122023;] sync - Sync[59226]: Added items: 4
    It seems to me that Calendar is not being synced, so every time it syncs, it shows the message "Sync states are not equals", and no changes on the calendar have been done.

    I resetted the device from the ZeXtras admin interface, i deleted and recreated the account on the mobile, with no success.

    Anyone can confirm if this device is really syncing or any test i can do to see more in depth?

    Thanks and regards

  2. #2
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Hello Toni!

    The only test I can suggest is to download an external ExchangeActiveSync client app (such as Touchdown, which comes with a 30-days trial), configure your account on the external client and see if the calendar is correctly synchronized.
    If it is, the problem is clearly caused by the stock client...

    Let us know the outcome of this test, I'll try to get my hands on a CM10 device to run some tests myself!


    Have a nice day,
    Cine
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  3. #3
    Active Member
    Join Date
    Mar 2012
    Posts
    16
    Hello Cine,

    TouchDown syncs perfectly, not showing those messages, and showing every event on my corporate calendar.

    I see clearly that this is a CM issue while syncing withActiveSync, i suppose it will also happen with other activesync servers, but i don't have any Exchange server to test.

    Thanks and regards!

  4. #4
    Active Member
    Join Date
    Mar 2012
    Posts
    16
    After the last upgrade to 1.8.7 (from 1.8.5), calendar on CM10 syncs perfectly, no upgrade to CM nor device reset has been done in the meantime.

    Thanks and regards!
    d0s0n likes this.

  5. #5
    Junior Member
    Join Date
    Jun 2013
    Posts
    1
    Quote Originally Posted by Toni Garcia View Post
    After the last upgrade to 1.8.7 (from 1.8.5), calendar on CM10 syncs perfectly, no upgrade to CM nor device reset has been done in the meantime.

    Thanks and regards!
    Hello Toni, I have the exact same issue (CM 10.0.0 on Nexus S). Could you please provide more details how you managed to get Outlook sync working? What application did you upgrade?

  6. #6
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Quote Originally Posted by rezorcinol View Post
    Hello Toni, I have the exact same issue (CM 10.0.0 on Nexus S). Could you please provide more details how you managed to get Outlook sync working? What application did you upgrade?
    Hello rezorcinol,
    welcome to the Fourums!

    Our good Toni here upgraded ZeXtras Suite from version 1.8.5 to 1.8.7...

    I'm not entirely familiar with CM Naming, but it's probable that the account type called "Outlook" is actually an Exchange WebServices account, not an Exchange ActiveSync one (which is the one needed for ZeXtras Mobile synchronization)... Commonly, the latter is referred to as either "Exchange ActiveSync", "EAS" or "Corporate Account".

    Again, I'm not familiar with CM10 namings, so if any CM10 user can shed some light it would be great

    Have a nice day,
    Cine
    the ZeXtras Team
    Last edited by Cine; 06-21-2013 at 01:43 PM.
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  7. #7
    Active Member
    Join Date
    Mar 2012
    Posts
    16
    As Cine stated, only zextras was upgraded.

    My CM version is some nightlies after 10.0.0, but I got same behavior with the stable version.

    Iirc, CM doesn't support EWS, only EAS (named corporate account)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •