Testing connection with Android 4.0.4 - not working
Results 1 to 5 of 5

Thread: Testing connection with Android 4.0.4 - not working

  1. #1
    Junior Member
    Join Date
    Nov 2012
    Posts
    2

    Testing connection with Android 4.0.4 - not working

    Hello,

    we have a Zimbra installation with LDAP, MTA, and mailboxes, version:
    Release 7.2.0_GA_2669.RHEL6_64_20120410002025 CentOS6_64 FOSS edition.

    And ZeXtras version 1.6.2 installed, initialized backups, tested, everything OK.
    Then I enabled ZxMobile on our default CoS and tryed connecting to it with my SGS2 Android version 4.0.4 and it failed.

    I input the data:
    Domain/user name:
    domain.com/some.user
    Password:
    secret
    Server:
    mail.domain.com
    Use SSL: No

    The device tryes to connect for a while then displays an error:
    Unable to complete
    You entered a wrong server address(clearly isn't), or the server is requesting a protocol not supported by the e-mail application.(translated)

    I did inspect zimbra logs however and found this in the logs:
    16:37:08.364:btpool0-0://mail.proplatform.net:81/Microsoft-Server-ActiveSync 86.58.43.27 GET null; Android/4.0.4-EAS-1.3
    16:37:08.364:btpool0-0://mail.proplatform.net:81/Microsoft-Server-ActiveSync 200 null 0

    What can I do?

    Thanks,
    Thomas

  2. #2
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,356
    Hello Thomas,
    welcome to the forums!

    I'd like you to answer a couple of questions in order to allow us to identify the cause of the issue:

    - In the device configuration, the "domain.com/some.user" part needs to be "domain.com\some.user" (with the backslash). Is the device correctly set?
    - I see that your server is responding on port 81: how did you set up this configuration? Remember that your device (along with the vast majority of the devices on the market) connects by default to port 80 for http and 443 for https and cannot be configured otherwise, so make sure that the routing between the device and the server is correct.

    Have a nice day,
    Cine

  3. #3
    Junior Member
    Join Date
    Nov 2012
    Posts
    2
    Hello Cine,
    thank you for replying!

    So sorry, the device configuration is indeed done with a backslash, not a normal slash. So yes, I believe it is correctly set.

    On the same server that is running Zimbra I also have an Apache web server running and listening on port 80, hence, that's why Zimbra is "forced" to listen on 81, IP limitations. Te redirect is done with Apache .htaccess file, like so:
    RewriteEngine On
    RewriteCond %{SERVER_PORT} !^81$
    RewriteRule (.*) http://%{HTTP_HOST}:81%{REQUEST_URI} [R]
    Hope this will help you identify the issue.

    Regards,
    Thomas



    Edit:
    Instead of using rewrites, I've now tried to configure a reverse proxy on apache, and it's working for webclient connections etc. and also I've progressed a bit with ZxMobile, it's not working yet tho, but the logs have changed:
    10:08:38.735:btpool0-27://mail.proplatform.net/Microsoft-Server-ActiveSync 86.58.43.27 OPTIONS null; Android/4.0.4-EAS-1.3
    10:08:38.735:btpool0-27://mail.proplatform.net/Microsoft-Server-ActiveSync 200 null 0
    10:08:38.810:btpool0-27://mail.proplatform.net/Microsoft-Server-ActiveSync?Cmd=FolderSync&User=proplatform.net%5Ct omaz.lovrec&DeviceId=androidc1436063681&DeviceType =Android 86.58.43.27 POST null; Android/4.0.4-EAS-1.3
    10:08:38.811:btpool0-27://mail.proplatform.net/Microsoft-Server-ActiveSync?Cmd=FolderSync&User=proplatform.net%5Ct omaz.lovrec&DeviceId=androidc1436063681&DeviceType =Android SUSPEND
    10:08:38.812:btpool0-27://mail.proplatform.net/Microsoft-Server-ActiveSync?Cmd=FolderSync&User=proplatform.net%5Ct omaz.lovrec&DeviceId=androidc1436063681&DeviceType =Android RETRY
    10:08:38.812:btpool0-27://mail.proplatform.net/Microsoft-Server-ActiveSync?Cmd=FolderSync&User=proplatform.net%5Ct omaz.lovrec&DeviceId=androidc1436063681&DeviceType =Android 503 application/vnd.ms-sync.wbxml 0
    It seems that I'm getting a 503 error, but no idea why.

    Edit2: I've got it working with Reverse Proxy now.
    The problem was quite strange, I've enabled mobile sync in the CoS, but after inspecting sync.log it said that the account was not enabled for mobile. So I disabled Mobile syncing for the CoS and enabled it for the account, and now it's working..
    Last edited by xfirestorm; 11-09-2012 at 09:45 AM.

  4. #4
    Active Member ZeXtras Reseller
    Join Date
    Nov 2012
    Posts
    3
    Hello,

    I know this has nothing to do with how this gentleman solved his issue but I have the exact same phone and after following the Wiki Mobile Sync guide I get nothing. Never even remotely looks like it is trying to contact the server. I attempted to setup logging for myself but when I go to that log I get one line and nothing else. 2012-11-10 09:16:51,724 [ZxLink Handler Thread] info Logging cody.betsworth@c2ithostingsolutions.com
    Thats all I get.. I have my staff and another company that are interested in licenses if we can get this to work. What should I do next? Thanks. Samsung Galaxy S 4.0.4 android. Setup COS default for mobile and also tried doing it at the email level as this fella did. Just says unable to locate server over and over. Any help is much appreciated? Install went smooth but setup has been a mess with this new phone.

    Cody Betsworth

  5. #5
    Active Member ZeXtras Reseller
    Join Date
    Nov 2012
    Posts
    3
    Great!!! It was an error on my part. Everything is working great. Thanks.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •