Exchange Active Sync - "protocol version not supported"
Results 1 to 6 of 6

Thread: Exchange Active Sync - "protocol version not supported"

  1. #1
    Active Member
    Join Date
    Mar 2015
    Posts
    3

    Exchange Active Sync - "protocol version not supported"

    I configured a Microsoft Exchange Active Sync account on my android device (Samsung galaxy S6). All is ok, except when i launch a search from my device i have the error message "protocol version not supported".
    The zimbra version is community 8.6.0_GA_1162

  2. #2
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,363
    Hello pgnitcheu,
    welcome to the forums!

    Samsung devices are limited by default to version 2.5 of the Exchange ActiveSync protocol to avoid protocol-compatibility issues found in almost all the Samsung roms since Android 4.0. You can change this in the ZxMobile section of the ZeXtras Administration Zimlet if there are no old Samsung devices connecting to the server, otherwise you can set up a dedicated rule for your account using the `doAddEASFilter` CLI command:

    Code:
    zxsuite mobile doAddEASFilter and account=user@example.com,contains=samsung fixed 14.1 blocking true
    This will force any device preseting itself with a string containing "samsung" to synchronize your mailbox using version 14.1 of the EAS protocol. In order to take effect, you'll need to remove the Exchange account from your device and reset the device's syncstate by deleting the relevant line in the "Devices" list within the ZxMobile section of the ZeXtras Administration Zimlet.

    Since this issue has never been reported before could you please let me know the Android version running on your device, the client used to sync the emails (default or third party) and confirm that you are running the latest version of ZeXtras Suite?

    Have a nice day,
    Cine
    the ZeXtras Team

  3. #3
    Member
    Join Date
    Nov 2012
    Posts
    26
    I can report that I have this problem with my S7. Thanks for the details on how to fix it. It was annoying not being able to search the server.

    Stephen

  4. #4
    Member
    Join Date
    Nov 2012
    Posts
    26
    Quote Originally Posted by Stephen J View Post
    I can report that I have this problem with my S7. Thanks for the details on how to fix it. It was annoying not being able to search the server.

    Stephen
    The search feature still isn't working. I'm thinking it is still trying to sync using 2.5. I checked sync.log

    2016-06-30 12:48:00,916 INFO [ZxMobile] [tid=195642;account=me.address@mydomain.com;id=SEC2 40E753FD2FFF;model=SAMSUNGSMG930V;proxy=192.168.0. 245;oip=192.168.8.87;eas=2.5;rid=47032;] sync - Requested push notification for folders: ...
    test(2309) with an heartbeat of 650 seconds.

    It says eas=2.5.

    I checked the rule and my addition is below a rule specifying 2.5 for samsungs. I tried using the doMoveEASFilter and it gave me the following error. "exception: Unable to move a filter before a static filter"
    Below is a dump of the filters that I have. 0-2 must be default because I never added any.

    ID 0
    mode fixed
    rule [type = or; rules = [[type = contains; rule = outlook/] OR [type = contains; rule = microsoft.outlook]]
    easversions 14.0
    blocking true

    ID 1
    mode limit
    rule [type = contains; rule = samsung]
    easversions 2.5
    blocking false

    ID 2
    mode limit
    rule [type = awlays]
    easversions 14.1
    blocking false

    ID 3
    mode fixed
    rule [type = and; rules = [[type = account; rule = myaddress@mydomain.com] AND [type = contains; rule = samsung]]
    easversions 14.1
    blocking true

  5. #5
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,363
    Hello Stephen!

    Did you delete the account from the device and reset its syncstate by removing the appropriate entry in the "Devices" list within the ZeXtras Mobile section of the Admin Zimlet?

  6. #6
    Member
    Join Date
    Nov 2012
    Posts
    26
    Cine,

    That was what I missed. I cleared that and then reconnected and now it is syncing at EAS 14.1. Thank you.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •