ZxLink Handler: Exception:
Results 1 to 3 of 3

Thread: ZxLink Handler: Exception:

  1. #1
    Active Member
    Join Date
    Jun 2015
    Posts
    17

    ZxLink Handler: Exception:

    Seeing this error alot in my logs not sure if its related to a potential sync issue or not

    2016-01-18 08:23:38,313 WARN [ZxLink Handler Thread] [] extensions - ZxLink Handler: Exception: com.zextras.lib.Error.PAPIStreamConnectionError: Connection Exception
    at com.zextras.lib.ZELinkStream.readPacket ( ZELinkStream.java:302 )
    at com.zextras.lib.ZELinkHandler.run ( ZELinkHandler.java:84 )
    Caused by: java.net.SocketException: Connection reset
    at java.net.SocketInputStream.read ( SocketInputStream.java:189 )
    at java.net.SocketInputStream.read ( SocketInputStream.java:121 )
    at java.net.SocketInputStream.read ( SocketInputStream.java:203 )
    at java.io.DataInputStream.readUnsignedByte ( DataInputStream.java:288 )
    at com.zextras.lib.ZELinkStream.readPacket ( ZELinkStream.java:242 )
    at com.zextras.lib.ZELinkHandler.run ( ZELinkHandler.java:84 )

    Is there anything I need to look at here?

  2. #2
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,360
    Hello scristopher!

    The error you report is common when interrupting the stream of a CLI command, such as the "monitor" one (`zxsuite backup monitor` or `zxsuite powerstore monitor`).
    Another common occurrence is when a mobile client drops the connection while synchronizing a shared folder which resides on another server within the same multistore infrastructure.

    Does the error appear in those cases or could you find anything else triggering it?

    Have a nice day,
    Cine
    the ZeXtras Team

  3. #3
    Active Member
    Join Date
    Jun 2015
    Posts
    17
    Quote Originally Posted by Cine View Post
    Hello scristopher!

    The error you report is common when interrupting the stream of a CLI command, such as the "monitor" one (`zxsuite backup monitor` or `zxsuite powerstore monitor`).
    Another common occurrence is when a mobile client drops the connection while synchronizing a shared folder which resides on another server within the same multistore infrastructure.

    Does the error appear in those cases or could you find anything else triggering it?

    Have a nice day,
    Cine
    the ZeXtras Team
    Hi Cine,
    The only thing I can think of that might be happening around this time is outlook trying to sync with the server. I've had a few accounts that sometimes will not sync with the server and looking at some other threads here I believe it was mentioned that this would be investigated after zextras 2.2.1 was released, not sure if this could be related or not as of yet.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •