Tzpush - Page 2
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 30
Like Tree4Likes

Thread: Tzpush

  1. #11
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Hello Mark!

    Just some quick pointers about Zimbra's GAL and ZxMobile (hope those are useful):

    - When the GAL is set up to use a GalSync, account the datasource is updated at regular intervals but can also be updated manually via a CLI command.
    - When the GAL is set up not to use a GalSync account the search is done straight on the LDAP (IIRC).
    - ZxMobile returns max. 20 results when searching the GAL, but you can both ask the server for a larger results pool or for specific intervals.

    Have a nice day,
    Cine
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  2. #12
    pgn
    pgn is offline
    Member
    Join Date
    Aug 2012
    Posts
    44
    installed the xpi in the OP.

    credentials entered in tzpush setting, device ID is auto-populated, and no errors.

    on tz sync, no action/sync occurs.

    in TBird error console, I see:

    "tzpush request status : reported -- 502"

    in Zimbra logs -- nothing, either.

  3. #13
    Developer of the tzpush Thunderbird add-on.
    Join Date
    Nov 2014
    Posts
    19
    Hi
    Download the latest version from thunderbird addons.

    What settings are you using?
    Server should be domain name only.
    http(s):// as per your server setup.
    User name should be name@yourserver.com (or .whaterver)
    Provisioning should be not checked.
    Override Display should be checked.

    set extensions.tzpush.debugwbxml to 1 in thunderbird preferences. This will allow for debuging.

    Try again and let me know results.

    Mark

    P.S. For anybody. The version now at Mozilla addons now supports Zextras

  4. #14
    pgn
    pgn is offline
    Member
    Join Date
    Aug 2012
    Posts
    44
    > Server should be domain name only.

    it is.

    > http(s):// as per your server setup.

    it is

    > User name should be name@yourserver.com (or .whaterver)

    it is

    > Provisioning should be not checked.

    it's not

    > Override Display should be checked.

    i see no such checkable option.

    about:config does have

    extensions.tzpush.displayoverride default boolean true

    > set extensions.tzpush.debugwbxml to 1 in thunderbird preferences. This will allow for debuging.

    done.

    now, (re)launching

    NSPR_LOG_MODULES="NNTP:0,SMTP:0,POP3:0,IMAP:4,sync :4,timestamp,nsHostResolver:4" NSPR_LOG_FILE="/home/gk/Desktop/tbird-debug.log" thunderbird

    on tx-sync, console shows,

    sending : <?xml version="1.0"?>
    <FolderSync xmlns="FolderHierarchy:">
    <SyncKey>0</SyncKey>
    </FolderSync>
    ----------
    tzpush request status : reported -- 502


    and @ exec of tz-sync,

    tail /home/gk/Desktop/tbird-debug.log
    2014-12-22 19:38:48.257117 UTC - 1828943680[7f4e6bd844a0]: Resolving host [my.admin-mail-domain.com] - bypassing cache.
    2014-12-22 19:38:48.257165 UTC - 1828943680[7f4e6bd844a0]: No usable address in cache for [my.admin-mail-domain.com]
    2014-12-22 19:38:48.257172 UTC - 1828943680[7f4e6bd844a0]: DNS thread counters: total=3 any-live=0 idle=3 pending=1
    2014-12-22 19:38:48.257180 UTC - 1828943680[7f4e6bd844a0]: DNS lookup for host [my.admin-mail-domain.com] blocking pending 'getaddrinfo' query: callback [7f4e023a3f60]
    2014-12-22 19:38:48.257207 UTC - 504284928[7f4e2256cf60]: DNS lookup thread - Calling getaddrinfo for host [my.admin-mail-domain.com].
    2014-12-22 19:38:48.257485 UTC - 1406138112[7f4e6bd84c80]: Resolving host [my.admin-mail-domain.com].
    2014-12-22 19:38:48.257520 UTC - 1406138112[7f4e6bd84c80]: Trying AF_UNSPEC entry for [my.admin-mail-domain.com] af: AF_INET.
    2014-12-22 19:38:48.257557 UTC - 1406138112[7f4e6bd84c80]: Checking blacklist for host [my.admin-mail-domain.com], host record [7f4e21fab820].
    2014-12-22 19:38:48.257579 UTC - 1406138112[7f4e6bd84c80]: Using positive cache entry for host [my.admin-mail-domain.com] but starting async renewal.
    2014-12-22 19:38:48.257595 UTC - 1406138112[7f4e6bd84c80]: DNS thread counters: total=3 any-live=0 idle=2 pending=1
    2014-12-22 19:38:48.257660 UTC - 1406138112[7f4e6bd84c80]: Checking blacklist for host [my.admin-mail-domain.com], host record [7f4e02365dc0].
    2014-12-22 19:38:48.257691 UTC - 529463040[7f4e2256cae0]: DNS lookup thread - Calling getaddrinfo for host [my.admin-mail-domain.com].
    2014-12-22 19:38:48.257854 UTC - 1406138112[7f4e6bd84c80]: Resolving host [my.admin-mail-domain.com] - bypassing cache.
    2014-12-22 19:38:48.257899 UTC - 1406138112[7f4e6bd84c80]: Host [my.admin-mail-domain.com] is being resolved. Appending callback [7f4e023a3fb0].
    2014-12-22 19:38:48.258402 UTC - 504284928[7f4e2256cf60]: DNS lookup thread - lookup completed for host [my.admin-mail-domain.com]: success.
    2014-12-22 19:38:48.258711 UTC - 529463040[7f4e2256cae0]: DNS lookup thread - lookup completed for host [my.admin-mail-domain.com]: success.
    2014-12-22 19:38:48.258770 UTC - 1406138112[7f4e6bd84c80]: Checking blacklist for host [my.admin-mail-domain.com], host record [7f4e02365dc0].

  5. #15
    Developer of the tzpush Thunderbird add-on.
    Join Date
    Nov 2014
    Posts
    19
    The latest version at mozilla addons will have the check option for display override.
    Can you confirm activesync is working. Do you connect using a mobile device?
    I can not reproduce the error. 501 is bad gateway.
    Is anything showing in server logs from tzpush?

  6. #16
    pgn
    pgn is offline
    Member
    Join Date
    Aug 2012
    Posts
    44
    > The latest version at mozilla addons will have the check option for display override.

    Installed it. Yes, the option is there now

    > Do you connect using a mobile device?

    Yes, from Android.

    For contacts, I normally connect via "ZCard" (proto: native) or CardDAV (proto: carddav); both of which are nonfunctional due to suspected problems handling the Zimbra mail proxy

    For calendar, "BusinessCalendar" (caldav, I believe). Works perfectly.

    > Can you confirm activesync is working.

    Per the Zimbra UI, ZxMobile is 'Running'.

    Testing from Android, I can successfully create a 'Corporate Email' (Exchange ActiveSync) account, with both IMAP/SMTP connections authenticated

    > I can not reproduce the error. 501 is bad gateway.
    > Is anything showing in server logs from tzpush?

    Launching TBird as

    NSPR_LOG_MODULES="NNTP:0,SMTP:0,POP3:0,IMAP:4,sync :4,timestamp,nsHostResolver:4" NSPR_LOG_FILE="/tmp/tzpush.log" thunderbird

    with

    extensions.tzpush.debugwbxml == 1

    on exec of tz-sync, log

    trace -f /tmp/tzpush.log | grep -i tz

    returns (empty) ... no activity shown.

  7. #17
    pgn
    pgn is offline
    Member
    Join Date
    Aug 2012
    Posts
    44
    saw this,

    https://community.zimbra.com/collabo...1897/t/1137014

    changed my zimbra "mail mode" from 'https' -> 'redirect', leaving tzpush's setting @ "use https".

    now, @ tz-sync, I *can* pull data from the Zimbra server into TBird. but, I can NOT push changes/updates from Tbird TO Zimbra using tz-sync.

    Might ask @Zimbra what mailmode their your test-account's server is set to ...
    Last edited by pgn; 12-28-2014 at 06:49 PM.

  8. #18
    Developer of the tzpush Thunderbird add-on.
    Join Date
    Nov 2014
    Posts
    19
    Could you add one new address, sync and post thunderbird error console xml.
    It would be good to have some guidance on setting up activesync on zextras. Everything works for me, I was fortunate to have it all set and ready to go.
    Mark

  9. #19
    pgn
    pgn is offline
    Member
    Join Date
    Aug 2012
    Posts
    44
    > Could you add one new address, sync and post thunderbird error console xml.

    Code:
    sending : <?xml version="1.0"?>
    <Sync xmlns="AirSync:">
    <Collections>
    <Collection>
    <Class>Contacts</Class>
    <SyncKey>a919dd932c3d4eb38d1474424e4b7585/7/36/4</SyncKey>
    <CollectionId>7</CollectionId>
    <DeletesAsMoves/>
    <GetChanges/>
    <WindowSize>100</WindowSize>
    <Options>
    <Conflict>1</Conflict>
    <MIMESupport>0</MIMESupport>
    </Options>
    </Collection>
    </Collections>
    </Sync>
     ----------
    sending : POST https://mailserver.mxdomain.com/Microsoft-Server-ActiveSync?Cmd=Sync&User=identity@domain1.com&DeviceType=Thunderbird&DeviceId=
     ----------
    recieved : <?xml version="1.0"?>
    <Sync xmlns="AirSync:">
    <Collections>
    <Collection>
    <Class>Contacts</Class>
    <SyncKey>a919dd932c3d4eb38d1474424e4b7585/7/36/4</SyncKey>
    <CollectionId>7</CollectionId>
    <Status>1</Status>
    </Collection>
    </Collections>
    </Sync>
     ----------
    Tue Dec 30 2014 07:07:19
    Error: malformed URI sequence
    Source file: chrome://tzpush/content/send.js
    Line: 27

  10. #20
    Developer of the tzpush Thunderbird add-on.
    Join Date
    Nov 2014
    Posts
    19
    I have uploaded a new version to mozilla which should fix this problem (umlaults).
    https://addons.mozilla.org/en-US/thu...push/versions/
    Mark

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •