About autodiscover setting
Results 1 to 5 of 5

Thread: About autodiscover setting

  1. #1
    Active Member
    Join Date
    Nov 2012
    Posts
    5

    About autodiscover setting

    Zimbra Version:Release 8.0.7_GA_6021.RHEL6_64_20140408123911 RHEL6_64 FOSS edition
    Zextras Version:1.10.1

    We have done the following setting:
    1 DNS record
    autodiscover.test.com. IN A 192.168.1.202
    _autodiscover IN SRV 0 5 443 test.com
    2 Jetty configuration
    edit /opt/zimbra/jetty/etc/jetty.xml.in
    change /service/autodiscover to /service/extension/autodiscover

    3 Edit my mobile phone DNS setting

    But create mail account on my mobile phone via Exchange mode, shows "can't connect to the server".

    1. Could you show me the correct DNS setting? My DNS server is CentOS named
    2. Which zimbra log I can check

  2. #2
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Hello cellopoint!

    Could you please try to access "autodiscover.test.com" from your device's web browser and tell me whether an error or the Zimbra WebClient login is displayed? Does the same thing happen when accessing the same URL from a computer within your LAN (as I assume you're working on a local DNS server)?

    Have a nice day,
    Cine
    the ZeXtras Team
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  3. #3
    Active Member
    Join Date
    Nov 2012
    Posts
    5
    Dear Cine,

    Please refer to the attached zip file, mobile's browser is OK.

    As I know, if the autodiscover is working, ActiveSync setting just need the info about mail address / account / password, don't need server info. Am i right?

    Please teach me how to set it up, or which log I can check.

    screenshot.zip

  4. #4
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Hello Cellopoint!

    I confirm that when the Autodiscover feature is properly working, you will just need to enter the information displayed in the first screenshot you posted...

    I see that "autodiscover.yourdomain.com" resolves properly to the Zimbra server, so the issue seems to be elsewhere. Could you please confirm that your server's SSL certificate is valid, provided by a trusted CA and includes the "autodiscover." subdomain either explicitly or via wildcard - as Android devices won't allow the Autodiscover to continue in any other case?

    Also, according to your DNS record
    Code:
    _autodiscover     IN     SRV 0 5 443 test.com
    the ip address 192.168.1.202 should belong to "test.com": is this your mailserver? If that's the IP address of "mail.test.com" the record should be changed to:
    Code:
    _autodiscover     IN     SRV 0 5 443 mail.test.com
    Have a nice day,
    Cine
    the ZeXtras Team
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  5. #5
    Active Member
    Join Date
    Nov 2012
    Posts
    5
    Dear Cine,

    Thanks for your help.
    Finally, we find out the root cause, Autodiscover feature supports iOS and Android 4.4.4+ only.

    Thanks,

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •