Autodiscover using wrong domain
Results 1 to 10 of 10

Thread: Autodiscover using wrong domain

  1. #1
    Active Member
    Join Date
    Nov 2014
    Posts
    5

    Autodiscover using wrong domain

    I just setup zxExtras on a trial for my company. It works great, but when configuring a new device (Outlook 2013, mobile clients, etc) there is an issue. The autodiscover function wants to initially make the domain for my email server be company.com, when in fact it is mail.company.com. I've looked everywhere in the Zimbra configuration settings and the domain is listed as mail.company.com everywhere. Can someone tell me specifically where autodiscover gets the domain it will supply to ActiveSync clients through autodiscover is located?

    Wes Keene

  2. #2
    Senior Member
    Join Date
    Oct 2014
    Posts
    89
    That isn't, strictly speaking, a domain name it's a subdomain. Why aren't you using company.com as the domain name? Did you not change the domain name when you were asked to install Zimbra? Is this a new install of Zimbra?

  3. #3
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,360
    Hello Wes and Phoenix,
    welcome to the forums!

    @Phoenix: I suppose that what Wes means by "domain" is actually the server's address, which is usually set to the email address' domain part if the AutoDiscover feature is not set up serverside...

    @Wes: Is my previous statement correct? If so, please have a look at this guide to find out how to properly configure the AutoDiscover feature...


    Have a nice day,
    Cine
    the ZeXtras Team

  4. #4
    Active Member
    Join Date
    Nov 2014
    Posts
    5
    Quote Originally Posted by Cine View Post
    Hello Wes and Phoenix,
    welcome to the forums!

    @Phoenix: I suppose that what Wes means by "domain" is actually the server's address, which is usually set to the email address' domain part if the AutoDiscover feature is not set up serverside...

    @Wes: Is my previous statement correct? If so, please have a look at this guide to find out how to properly configure the AutoDiscover feature...


    Have a nice day,
    Cine
    the ZeXtras Team
    Yes, I meant that a client using autodiscover will be directed to use a server address of company.com, where clearly the mail server resides at mail.company.com. Cine, I have followed the instructions provided at that link, and I believe my autodiscover service is functioning (I went with a CNAME record, btw). The jetty change was easy, and I did it the first day. We use 8.0.5. I don't see anything in those instructions that would pertain to which address is being handed out to clients, though.

    Wes

  5. #5
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,360
    Hello Wes!

    The Autodiscover feature will return the value of the "zimbraPublicServiceHostname" domain property. Should such property be empty, it will fall back to the value of the "zimbraServiceHostName" server property.

    The domain name is either sent explicitly by the client or deduced by the http/s request sent by the mobile phone.

    Have a nice day,
    Cine
    the ZeXtras Team
    Last edited by Cine; 11-13-2014 at 04:47 PM. Reason: Fixed property name

  6. #6
    Active Member
    Join Date
    Nov 2014
    Posts
    5
    Quote Originally Posted by Cine View Post
    Hello Wes!

    The Autodiscover feature will return the value of the "zimbraPublicHostname" domain property. Should such property be empty, it will fall back to the value of the "zimbraServiceHostName" server property.

    The domain name is either sent explicitly by the client or deduced by the http/s request sent by the mobile phone.

    Have a nice day,
    Cine
    the ZeXtras Team
    Thanks. I went digging around for that. I can't come up with any Zimbra admin documentation on that property name. The one potentially applicable property I could find was the value set by "zmsetservername" and (I believe) reflected by the Zimbra Admin interface under Configure/Domains. In fact the domain listed there is company.com, because mail should be delivered to user@company.com. If I were to change that to the subdomain, I believe all users would be required to have email addresses of the form user@webmail.company.com or similar. That is not desirable.

    If I am not looking in the right place, please let me know.

  7. #7
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,360
    Hello Wes!

    The `zmsetservername` command is not related to this kind of setting, and AFAIR it makes multiple changes in Zimbra's configuration and LDAP.

    The "zimbraPublicServiceHostName" property can be found in the Zimbra Administration Console under Configure->Domains->[yourdomain.com]->General-> "Public Service Hostname":

    Code:
    zimbra@test:~$ zmprov describe -a zimbraPublicServiceHostName
    zimbraPublicServiceHostname
        Name to be used in public API such as REST or SOAP proxy.
    
    
                   type : string
                  value : 
               callback : 
              immutable : false
            cardinality : single
             requiredIn : 
             optionalIn : globalConfig,domain
                  flags : domainInfo,domainInherited
               defaults : 
                    min : 
                    max : 256
                     id : 377
        requiresRestart : 
                  since : 
        deprecatedSince :
    (it seems that I misspelled the property name in my previous post, sorry about that)

    To sum up: if the "zimbraPublicServiceHostName" property is set at either domain or globalConfig level, the value of such property will be used (the same is used for many other ). Otherwise, the value of the "zimbraServiceHostname" server property will be used.

    Have a nice day,
    Cine
    the ZeXtras Team

  8. #8
    Active Member
    Join Date
    Nov 2014
    Posts
    5
    Interesting. I've configured that setting in the Administrative UI, but it does not seem to be helping. I also added it via command line just to be sure, same result. When I run the describe command (as you did above), I see no value displayed, even after executing the command to set it. It's bizarre.

  9. #9
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,360
    Hello Wes!

    Updating this thread after a long time as the Dev Team notified me that a bug related to the issue you reported has been found and fixed. I'll send you a PM with all due information in a couple of minutes

    Have a nice day,
    Cine
    the ZeXtras Team

  10. #10
    Active Member
    Join Date
    Nov 2014
    Posts
    5
    This is wonderful. I'll get it installed as soon as I'm able to, and let everyone know if it resolves the issue I was seeing.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •