ActiveSync randomly stops working Blackberry 10 since 1.8.17 upgrade
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 39

Thread: ActiveSync randomly stops working Blackberry 10 since 1.8.17 upgrade

  1. #1
    Member
    Join Date
    Aug 2013
    Posts
    39

    ActiveSync randomly stops working Blackberry 10 since 1.8.17 upgrade

    After the upgrade to 1.8.17 I am now having a very annoying issue with my Blackberry Q10.

    If I reboot the phone everything works fine, HTML randomly does and doesn't work (some e-mails load in HTML view and some don't) and then after a few days e-mail stops syncing and the phones PIM Service (Personal information management - BlackBerry Native) starts burning through the battery with heavy CPU utilization.

    Reboot the phone and everything works fine again for a few days.


    Server information
    OS: CentOS 6.5 64-bit
    CPU: Intel Xeon E3-1230 V2
    RAM: 32GB
    Storage: LSI MegaRAID MR9270-8i (2x1TB RAID1, 6x3TB RAID6)

    Zimbra version: 8.0.7 64-bit

    ZeXtras info:
    zxsuite core getVersion

    zextras_version 1.8.17
    zextras_target 8.0.7
    zextras_commit 75c2d883fb87d042042446f1895402186b2d4c3e
    zextras_lib_version 1.0.0
    zextras_lib_commit 85a77116da6aeb0d5362eec2cb7d8d2b2d3e3825

    I am using Apache 2.2.15 and mod_proxy in front of my Zimbra server because I use Port 80/443 for a web server on the same server. This setup was working fine (except that no HTML e-mail would load) previous to the upgrade.

    Here is my vHost/Proxy settings in Apache:

    Code:
    <VirtualHost *:80>
           ServerName mail.mydomain.com
           DocumentRoot /data/wwwPublic/siteMain
           CustomLog logs/mail.mydomain.com.log combined
           ErrorLog logs/mail.mydomain.com-error.log
    
           RewriteEngine On
           RewriteCond %{SERVER_PORT} 80
           RewriteRule ^(.*)$ https://mail.mydomain.com$1 [R,L]
    
    </VirtualHost>
    <VirtualHost *:443>
            ServerName mail.mydomain.com
            DocumentRoot /data/wwwPublic/siteMain
            CustomLog logs/mail.mydomain.com.log combined
            ErrorLog logs/mail.mydomain.com-error.log
    
            ProxyRequests On
            ProxyPreserveHost On
            Keepalive On
            ProxyPass / http://127.0.0.1:65521/
            ProxyPassReverse / http://127.0.0.1:65521/
    
            SSLEngine on
            SSLProtocol all -SSLv2
            SSLCipherSuite ECDHE-RSA-AES128-SHA256:AES128-GCM-SHA256:RC4:HIGH:!MD5:!aNULL:!EDH
            SSLCertificateFile /etc/httpd/conf/certs/mydomain.com.crt
            SSLCertificateKeyFile /etc/httpd/conf/certs/mydomain.com.key
            SSLCertificateChainFile /etc/httpd/conf/certs/sub.class2.server.sha2.ca.pem
            SSLCACertificateFile /etc/httpd/conf/certs/ca-sha2.pem
    </VirtualHost>
    The only errors I see in my apache logs are:

    Code:
    [Mon Aug 18 09:56:03 2014] [error] [client xxx.xxx.xxx.xxx] proxy: Error reading from remote server returned by /Microsoft-Server-ActiveSync
    [Mon Aug 18 09:57:58 2014] [error] [client xxx.xxx.xxx.xxx] (70007)The timeout specified has expired: proxy: error reading status line from remote server 127.0.0.
    1
    [Mon Aug 18 09:57:58 2014] [error] [client xxx.xxx.xxx.xxx] proxy: Error reading from remote server returned by /Microsoft-Server-ActiveSync
    [Mon Aug 18 09:58:09 2014] [error] [client xxx.xxx.xxx.xxx] (70007)The timeout specified has expired: proxy: error reading status line from remote server 127.0.0.
    1
    [Mon Aug 18 09:58:09 2014] [error] [client xxx.xxx.xxx.xxx] proxy: Error reading from remote server returned by /Microsoft-Server-ActiveSync
    [Mon Aug 18 10:00:03 2014] [error] [client xxx.xxx.xxx.xxx] (70007)The timeout specified has expired: proxy: error reading status line from remote server 127.0.0.
    1
    [Mon Aug 18 10:00:03 2014] [error] [client xxx.xxx.xxx.xxx] proxy: Error reading from remote server returned by /Microsoft-Server-ActiveSync
    [Mon Aug 18 10:00:16 2014] [error] [client xxx.xxx.xxx.xxx] (70007)The timeout specified has expired: proxy: error reading status line from remote server 127.0.0.
    1
    [Mon Aug 18 10:00:16 2014] [error] [client xxx.xxx.xxx.xxx] proxy: Error reading from remote server returned by /Microsoft-Server-ActiveSync
    [Mon Aug 18 10:02:09 2014] [error] [client xxx.xxx.xxx.xxx] (70007)The timeout specified has expired: proxy: error reading status line from remote server 127.0.0.
    1
    [Mon Aug 18 10:02:09 2014] [error] [client xxx.xxx.xxx.xxx] proxy: Error reading from remote server returned by /Microsoft-Server-ActiveSync
    [Mon Aug 18 10:02:23 2014] [error] [client xxx.xxx.xxx.xxx] (70007)The timeout specified has expired: proxy: error reading status line from remote server 127.0.0.
    1
    [Mon Aug 18 10:02:23 2014] [error] [client xxx.xxx.xxx.xxx] proxy: Error reading from remote server returned by /Microsoft-Server-ActiveSync
    [Mon Aug 18 10:04:17 2014] [error] [client xxx.xxx.xxx.xxx] (70007)The timeout specified has expired: proxy: error reading status line from remote server 127.0.0.
    1
    [Mon Aug 18 10:04:17 2014] [error] [client xxx.xxx.xxx.xxx] proxy: Error reading from remote server returned by /Microsoft-Server-ActiveSync
    [Mon Aug 18 10:04:29 2014] [error] [client xxx.xxx.xxx.xxx] (70007)The timeout specified has expired: proxy: error reading status line from remote server 127.0.0.
    1
    [Mon Aug 18 10:04:29 2014] [error] [client xxx.xxx.xxx.xxx] proxy: Error reading from remote server returned by /Microsoft-Server-ActiveSync
    Which are ongoing since well before the upgrade to 1.8.17.

    I currently have a debug logger running (after the point when e-mail stopped syncing) and nothing is appearing in the logs after 15 minutes. I am going to assume connectivity has been completely lost.

    I am going to reboot my phone now and keep the debug log running until the connection craps out again.

    My ZxMobile settings are all default.

    I will post the debug log after the next disconnect. In the mean time do my proxy settings look correct? Do you recommend any specific settings for doing this kind of thing? I can't be the only one with one server and one IP address running multiple services.

  2. #2
    Wise Guy Participant
    Join Date
    Apr 2011
    Posts
    34
    Hello FiZi .

    Could you provide us the portion of the sync.log file under /opt/zimbra/log referring to the same time window of the apache logs, in order to correlate the two?
    It would also be helpful to have the original apache logs with the actual ip addresses. You can send us that to community(@at@)zextras.com .

    On a hunch, is it possible that you lost the ZeXtras "Max ping heartbeat" setting configured as suggested in this old conversation when you removed the ZeXtras configuration in order to address the problem discussed in this one?

    Regards
    ZeXtras Website # ZeXtras Wiki # ZeXtras Store

    ZeXtras System Administrator and Installer Guru

  3. #3
    Member
    Join Date
    Aug 2013
    Posts
    39
    Quote Originally Posted by Trantor View Post
    Hello FiZi .

    Could you provide us the portion of the sync.log file under /opt/zimbra/log referring to the same time window of the apache logs, in order to correlate the two?
    It would also be helpful to have the original apache logs with the actual ip addresses. You can send us that to community(@at@)zextras.com .

    On a hunch, is it possible that you lost the ZeXtras "Max ping heartbeat" setting configured as suggested in this old conversation when you removed the ZeXtras configuration in order to address the problem discussed in this one?

    Regards
    There is nothing new in my sync.log since August 12th. With out a sync.log is there any use in sending you the unedited apache logs? Also why is my sync.log blank? The last entries are:

    Code:
    2014-08-12 11:27:15,532 INFO  [ZxMobile Notifier] [tid=64;] sync - ZxMobile Notifier: Shutting down
    2014-08-12 11:28:05,888 INFO  [ZeXtras Activity Thread] [] sync - Starting ZeXtras Autodiscover zimlet
    My "Max ping heartbeat" setting has gone back to the default (0) after I had to fix another issue with ZxMobile after the upgrade. I swear I read some where if it's set to '0' then the device governs it's own heartbeat. What setting should this be? 300s? Looks like Microsoft Exchange uses a default of 480s (Heartbeat Interval Adjustment).


    Update - 2014-08-19 @ 09:42 PST

    Quick update.

    I changed my heartbeat to 480s and restarted Zimbra and my phone.

    My sync.log now shows:

    Code:
    2014-08-19 09:38:51,337 INFO  [ZeXtras Activity Thread] [] sync - Starting ZeXtras Autodiscover zimlet
    Lets see if that fixes things.
    Last edited by FiZi; 08-19-2014 at 05:43 PM.

  4. #4
    CTO ZeXtras Employee d0s0n's Avatar
    Join Date
    Apr 2011
    Posts
    565
    Hi FiZi,

    you are using a non-standard enviroment with apache as reverse proxy with a short timeout (default timeout in apache is 300 seconds), so you need to limit the activesync Heartbeat to a lower value or I suggest to increase the timeout on your custom proxy.
    The zimbra-proxy service (nginx) uses 3600 seconds as default value:

    Code:
    /opt/zimbra/conf/nginx/includes/nginx.conf.web.http
    location ^~ /Microsoft-Server-ActiveSync
        {
            include             /opt/zimbra/conf/nginx/includes/nginx.conf.web.http.mode-both;
            #[..CUT..]
            set $mailhostport 8080;   # replace this with *the* mailhost port
            set $relhost $host;
    
            if ($mailhostport != 80) {   # standard HTTP port, do not replace
                set $relhost $host:$mailhostport;
            }
    
            # End stray redirect hack
    
            # Proxy to Zimbra Upstream
            proxy_pass         http://zimbra;
            proxy_read_timeout 3600;
            proxy_buffering    off;
    About your log pupulation, you need to check the zextras log level on zimbra administration console -> Zextras Core settings or via Zextras CLI:
    Code:
    ~$ zxsuite core getproperty ZxCore_LogLevel
    D0s0n
    ZeXtras Website # ZeXtras Wiki # ZeXtras Store

    Head of ZeXtras System Administrators

  5. #5
    Member
    Join Date
    Aug 2013
    Posts
    39
    Here is my logging level

    Code:
    myhost.com:~ zimbra$zxsuite core getproperty ZxCore_LogLevel
    
    ZxCore_LogLevel                                             2 (1)
    I have made the following tweak to my proxy configuration and left my ZxMobile heartbeat at 480s:

    Code:
            ProxyRequests On
            ProxyPreserveHost On
            Keepalive On
            ProxyTimeout 3600
            ProxyPass / http://127.0.0.1:65521/
            ProxyPassReverse / http://127.0.0.1:65521/
    It does seem when the timeout is hit my Blackberry's PIM service starts showing high CPU usage.

    A restart of Apache on my server then calms it back down to idle.

  6. #6
    CTO ZeXtras Employee d0s0n's Avatar
    Join Date
    Apr 2011
    Posts
    565
    Quote Originally Posted by FiZi View Post
    Here is my logging level
    Code:
    myhost.com:~ zimbra$zxsuite core getproperty ZxCore_LogLevel
    ZxCore_LogLevel                                             2 (1)
    I don't understand, you are complaining about your empty sync.log but you have set your log level to warning value (2), so only warning messages are written on that file. If you want to have a standard verbosity you need to set the default value info (1):
    Code:
    myhost.com:~ zimbra$zxsuite core setproperty ZxCore_LogLevel 1
    Quote Originally Posted by FiZi View Post
    I have made the following tweak to my proxy configuration and left my ZxMobile heartbeat at 480s:

    Code:
            ProxyRequests On
            ProxyPreserveHost On
            Keepalive On
            ProxyTimeout 3600
            ProxyPass / http://127.0.0.1:65521/
            ProxyPassReverse / http://127.0.0.1:65521/
    Same thing here: you can set the ZxMobile heartbeat to 0 or at least to a value a bit lower than 3600.


    Quote Originally Posted by FiZi View Post
    It does seem when the timeout is hit my Blackberry's PIM service starts showing high CPU usage.

    A restart of Apache on my server then calms it back down to idle.
    It's very hard to guess this issue without see any log, as stated on our troubleshooting guide (section 3.7.1) the next time you can activate a debug logger for the specific account activities.

    D0s0n
    ZeXtras Website # ZeXtras Wiki # ZeXtras Store

    Head of ZeXtras System Administrators

  7. #7
    Member
    Join Date
    Aug 2013
    Posts
    39
    Quote Originally Posted by d0s0n View Post
    I don't understand, you are complaining about your empty sync.log but you have set your log level to warning value (2), so only warning messages are written on that file. If you want to have a standard verbosity you need to set the default value info (1):
    Code:
    myhost.com:~ zimbra$zxsuite core setproperty ZxCore_LogLevel 1
    I had my logging level set to warning. I had assumed any issues would be a warning or higher in my logs. I have changed the logging to debug and will retrieve the relevant logs for this post if the issue persists. We may have fixed it by changing the apache timeout and the heartbeat value.


    Quote Originally Posted by d0s0n View Post
    Same thing here: you can set the ZxMobile heartbeat to 0 or at least to a value a bit lower than 3600.
    Going to leave the heart beat at 480s. It's the Microsoft Exchange default, I use ActiveSync with Exchange 2010 and have no problems with my Blackberry, seems like a good place to start.


    Quote Originally Posted by d0s0n View Post
    It's very hard to guess this issue without see any log, as stated on our troubleshooting guide (section 3.7.1) the next time you can activate a debug logger for the specific account activities.
    I understand. I will be sure to have the proper logs if the issue persists and will reply here.

  8. #8
    CTO ZeXtras Employee d0s0n's Avatar
    Join Date
    Apr 2011
    Posts
    565
    Hi FiZi,

    please remember to keep an eye on size of your logs because using the debug level could fill your disk.

    About the Heartbeat, don't forget that a low value can impact on device batteries.

    Have a nice day.
    D0s0n
    ZeXtras Website # ZeXtras Wiki # ZeXtras Store

    Head of ZeXtras System Administrators

  9. #9
    Member
    Join Date
    Aug 2013
    Posts
    39
    Darn. I was hoping it was fixed.

    Sending you the relevant logs. Here is a rough time line.

    ~9:00am-10:40am e-mail syncing stopped, phone went high CPU usage
    10:40 new e-mail came in to my webmail and didn't sync to phone (this is when I noticed the issue and high CPU usage)
    10:46 rebooted phone
    ~10:48 syncing started to work again

    The logs include before and after the above time line.

  10. #10
    Jay
    Jay is offline
    Code Master ZeXtras Employee
    Join Date
    May 2011
    Posts
    26
    Hello FiZi,

    From what i can understand from your logs, at 10:50:20 the device changed the retention policy of "/Sent" folder from infinite retention to 23 days, causing tens of ""these messages are out of retention"" replies (SoftDelete) which probably stopped the device from receiving new emails until all messages were reported as out of retention.

    Did you actually visit the /Sent folder at 10:50? Was it the first time you did it since you created the account on the device?
    Did you change device options at 10:50, even unrelated ones?
    Did you restart mailboxd in the log timeframe?
    Do you remember what retentions policies (how many days) were set?

    Regards
    ZeXtras Website # ZeXtras Wiki # ZeXtras Store

    Head of ZeXtras Suite Developers

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •