Repeatable mailstore/zxChat problem
Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Repeatable mailstore/zxChat problem

  1. #1
    Active Member
    Join Date
    Sep 2016
    Posts
    12

    Repeatable mailstore/zxChat problem

    Hello everybody,

    First of all, thank you zeXtras team for delivering funcionalities we need!

    However for past few weeks I have been struggling with a serious problem and I ran out of ideas.
    I have opened a support case with Zimbra, but they are blaming zXChat, so my last resort is actually this community.
    From time to time (issue seems to be random - sometimes once a day, sometimes 3 times a day) our mailstore servers will start throwing 502 errors to the clients.
    In the mailbox log I can find all of registered user chat sessions going offline and then trying to re register.

    Few words regarding our arch:
    One proxy server, one ldap, 7 store servers = ~4k mailboxes. Running Centos 7 and Zimbra 8.6.6 NE.

    I've uploaded part of mailbox.log to http://pastebin.com/jTn1YDMQ

    The only workaround for the issue is to restart mailbox on the server and it will work for some time.

    Sorry for the long post but I'm quite desperate to solve this problem.
    I've removed domain info from the log for little anonimity.

  2. #2
    Member
    Join Date
    Oct 2014
    Posts
    32
    I'd guess it might be useful to mention which version of ZeXtras & zxChat you're using. When you say that Zimbra is 'blaming zxChat', did they enlighten you on what the problem is or might be?
    Regards


    Bill

  3. #3
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,311
    Hello Zeol,
    welcome to the forums!

    Phoenix is correct, knowing the Zextras Suite and Zextras Chat Zimlet version you are running would give us a better insight of the issue

    By the logs you sent it appears it might be related to the configuration storage, which has been greatly improved in 2.4.0 - so if you are running an older version please upgrade to the latest and let me know if the issue still happens.
    Another possible reason is the garbage collector taking too much time and making the configuration storage to timeout and hang, but that would require a deeper investigation: if you are running Zextras Suite 2.4.0 or if the issue persists after the upgrade, please open a support ticket at Zextras Support Portal mentioning the URL of this thread in the ticket's content...

    Have a nice day,
    Cine
    the Zextras Team
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  4. #4
    Active Member
    Join Date
    Sep 2016
    Posts
    12
    Hello Phoenix, Cine.

    Sorry for missing this important detail. I'm running ZeXtras 2.2.5 and plan to upgrade over the weekend.
    As for Zimbra support blaming ZeXtras, here is the part of the conversation:

    [START]

    [..] Following are the visible alerts of Zextras in the mailbox.log at that time range.

    (here they paste unrelevant connection error to the server that was offline at that particular moment) [..]

    Please see the soap invocation count around 11 this indicates that this issue is happening because of the Zextra zimlet.



    Please disable the zextra zimlet and observe if getting issues.


    [END]

    Unfortunately I think they are trying to convince us to switch to Zimbra Talk

    Again thank you guys for being so responsive

  5. #5
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,311
    Hello zeol!

    I've discussed your case with the devs and they'd like to have more information about it: since this would include some logs and other info that are not suitable to be posted on a public forum could you please open a support ticket on the Zextras Support Portal using the same subject as this thread's title and mentioning both your Zextras Chat Zimlet version and this thread's URL in the body?

    Have a nice day,
    Cine
    the Zextras Team
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  6. #6
    Active Member
    Join Date
    Sep 2016
    Posts
    12
    Hey Cine,

    Thank you for deepdiving into it.
    I've opened a ticket as requested
    Zextras Support Portal

    Cheers!

  7. #7
    Active Member
    Join Date
    Sep 2016
    Posts
    12
    Actually one extra question, probably should open another thread but I'll give it a chance here.

    Is it normal that when I migrate user mailbox from one mailstore to another, the user will loose all the contacts in chat roster ?
    Yesterday I've come upon this issue when migrating my account to another server. Had to migrate back to solve it (otherwise I would have to re-add every contact).

  8. #8
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,311
    Hello zeol!

    You mean when using Network Edition's "zmmailboxmove" tool?
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  9. #9
    Active Member
    Join Date
    Sep 2016
    Posts
    12
    Quote Originally Posted by Cine View Post
    Hello zeol!

    You mean when using Network Edition's "zmmailboxmove" tool?
    It's zmmboxmove as I think zmmailboxmove is deprecated

    Following scenario I've tested on myself:

    My account exists on server zstore01: I have 10 buddied added in my ZxChat (I'm using ZxChat in webclient and from time to time from external jabber communicator Gajim).
    I'm doing zmmboxmove to server zstore02.

    Situation is as follows:

    1. I don't have any buddies in roster
    2. My buddies see me as offline, some of them still CAN send me messages but I cannot reply to them
    3. I have to manually re-add everybody, buddies do not have to accept my requests, they will be automatically accepted.
    4. When I migrate myself back to zstore01 situation return to the previous state

    Is buddy list kept locally on each mailstore ?

    Cheers,

  10. #10
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,311
    Hello Zeol!

    You're right, "zmmailboxmove" was deprecated in favor of "zmmboxmove" quite some time ago, my bad

    I've asked the Dev Team for clarifications about this specific scenario and I'm waiting for their feedback, I'll report back to you ASAP...

    Have a nice day,
    Cine
    the Zextras Team
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •