Adding 2 Users as Buddies in the Zextras Chat
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Adding 2 Users as Buddies in the Zextras Chat

  1. #1
    Active Member
    Join Date
    Apr 2015
    Posts
    8

    Adding 2 Users as Buddies in the Zextras Chat

    Hi

    I am trying to add users as buddies from the backend (CLI) using the following command

    zxsuite chat doAddBuddies user1@xyz.com user2@xyz.com

    When I do this I am able to see user2 in user1 but not vice versa.

    When i try to add user1 as buddy to user2 from frontend (zimbra webgui) it works.

    Can someone let me how to add 2 users as buddies from CLI ...

    Thanks.

  2. #2
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Hello manohar.m,
    welcome to the forums!

    The "doAddBuddies" command is exactly what you're looking for, but the behaviour you describe isn't the expected one indeed...

    In order to help us investigate the cause, could you please:
    - Let me know your Zimbra and ZeXtras Suite versions
    - Try to add two different users to each others' buddy list using the CLI and post here any error/warning/info message appearing in the mailbox.log when you do so.
    - Try to add two different users to each others' buddy list using the ZeXtras Administration Zimlet (ZxChat section) and check whether the result is the same as the CLI.

    Have a nice day,
    Cine
    the ZeXtras Team
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  3. #3
    Active Member
    Join Date
    Apr 2015
    Posts
    8
    Hi Cine,

    Thanks for your reply, I am running zextras suit version 10.10.2 and chat version 1.26. The odd thing is GUI version of AdBuddies is not working at all. When I click on add it does not do anything. I am running CentOS 6.6 x64bit edition.

    Please help !

  4. #4
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Hello manohar.m!

    I remember of a known issue with version 1.10.2 which could cause the "Add Buddies" feature to behave oddly in some limited cases, could you please update ZeXtras Suite to version 1.10.3 and retry? If it doesn't work with 1.10.3 please post the information I mentioned in my previous post (error/warn/info messages in the mailbox.log while running the command).

    Have a nice day,
    Cine
    the ZeXtras Team
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  5. #5
    Active Member
    Join Date
    Apr 2015
    Posts
    8
    Hi Cine,

    Upgraded but no luck, the command acknowledges that the users are added as buddies

    zxsuite chat doAddBuddies manohar.m@xyz.com chanakya.g@xyz.com
    Users manohar.m@xyz.com and chanakya.g@xyz.com are now buddies.

    The logs shows no warnings or errors, please find the log below

    2015-04-24 09:52:36,291 INFO [qtp509886383-775:https://198.50.142.201:7071/service/admin/soap/zextras] [name=chanakya.g@xyz.com;mid=10;ip=183.82.96.231;ua =ZimbraWebClient - GC42 (Win);] soap - zextras elapsed=2
    2015-04-24 09:52:42,861 INFO [qtp509886383-800:https://198.50.142.201:7071/service/admin/soap/zextras] [name=manohar.m@xyz.com;mid=11;ip=183.82.96.231;ua= ZimbraWebClient - GC42 (Win);] soap - zextras elapsed=2

  6. #6
    CTO ZeXtras Employee d0s0n's Avatar
    Join Date
    Apr 2011
    Posts
    565
    Hi manohar.m,

    have you reload the zimbra page on both user before check the buddy lists?

    D0s0n
    ZeXtras Website # ZeXtras Wiki # ZeXtras Store

    Head of ZeXtras System Administrators

  7. #7
    Active Member
    Join Date
    Apr 2015
    Posts
    8
    Yes, I did. In fact I have cleared the cache too ...

  8. #8
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Hello manohar.m!

    Our Devs found and fixed the cause of this issue, which will be solved in ZeXtras Suite 2.0...

    Have a nice day,
    Cine
    The ZeXtras Team
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  9. #9
    Active Member
    Join Date
    Apr 2015
    Posts
    8
    Thanks Cine,

    Any update on when this version is going to be released ?

    Thanks.

  10. #10
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Hello manohar.m!

    ZeXtras Suite 2.0 will be released VERY soon!

    In the meantime, the devs told me that as a workaround you can simply reverse the order of the users of the commands you launched originally for it to work: should you need to add more buddies, simply run the command two times switching the first and second users (I know it's a silly workaround, but it works).

    Have a nice day,
    Cine
    the ZeXtras Team
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •