Unable to create backup directory: /opt/zimbra/backup/zextras/ ?
Results 1 to 4 of 4
Like Tree1Likes
  • 1 Post By nixy32

Thread: Unable to create backup directory: /opt/zimbra/backup/zextras/ ?

  1. #1
    Active Member
    Join Date
    May 2013
    Posts
    10

    Question Unable to create backup directory: /opt/zimbra/backup/zextras/ ?

    Hi

    Thanks for writing such an amazing suite of programs, I can't even begin to tell you how much the migration modules have reduced the immense stress of migrating our system from ZCS6 to ZCS8

    We're running Zimbra virtualized in a Centos 6.4 VirtualBox system, that's going great.

    I have a 147GB SAS drive containing the VM for Zimbra, a 70GB SAS drive for the Host OS / other VMs, and a larger 640GB SATA drive for bulk secondary storage and for later backup to tape

    I'm trying to use the shared folder guest addition facility to store the zextras backup onto the SATA drive and failing

    Making sure the zimbra user is added to the vboxsf group I've tried both pointing the backup path box to both /media/sf_backup and making a sym link from /opt/zimba/backup to the sf_backup folder

    The problem is whenever I click on the "Initialize NOW!" button I get the following message

    "Unable to create backup directory: /opt/zimbra/backup/zextras/"


    [root@mail zimbra]# ls -l backup
    lrwxrwxrwx 1 root root 30 May 8 13:26 backup -> /media/sf_backup/zimbra-backup

    [zimbra@mail media]$ ls -l /media/
    drwxrwx--- 1 root vboxsf 4096 May 8 11:58 sf_backup

    [root@dmz mnt]# ls -l backup/
    drwxrwsrwx 3 root vboxusers 4096 May 8 15:52 zimbra-backup

    [zimbra@mail media]$ groups
    zimbra adm tty postfix vboxsf

    So there's no reason that zimbra cannot write to that folder

    In-fact if I su to zimbra and then mkdir zextras in /media/sf_backup/zimbra-backup it works fine

    [zimbra@mail zimbra-backup]$ pwd
    /media/sf_backup/zimbra-backup

    [zimbra@mail zimbra-backup]$ mkdir zextras

    [zimbra@mail zimbra-backup]$ ls -l
    drwxrwx--- 1 root vboxsf 4096 May 8 16:52 zextras

    I then re-run the "Initialize NOW!" button and get the same error

    If I don't try such tactics and do the initialize step on the host disk it works and starts writing out, but not in the right area :-(

    Can anyone shed some light on what I'm doing wrong here?

  2. #2
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,363
    Hello nixy32!

    I'll check the logics behind that check with the devs and I'll report back to you ASAP...

    Have a nice day,
    Cine

  3. #3
    Wise Guy Participant
    Join Date
    Apr 2011
    Posts
    34
    Hello nixy32 .

    My colleagues have tried to reproduce the steps you've shown us, without stumbling into any problem.
    The main difference between your setup and ours is the use of VirtualBox and the vboxfs volume.
    Frankly we have no idea how the java vm might interact with that fs, although on a theoretical basis what you did manually should not be any different from what the java vm does on its own.
    It's strange how you reported that the same error, the «Unable to create backup directory» error, was shown even though you had physically created the directory prior to trying again. That puzzles us. Are you certain the the message remains exactly the same?

    Since initializing the backup on the other volume worked, the fault would appear to lie with the target volume, or its permissions.
    Just to verify unlikely circumstances, have you tried using the actual path to the directory you wish to use, without using symlinks? Or relaxing the permissions, allowing access to all users and setting the uid/gid of the directory to zimbra/zimbra?

    Another source of mischief might be the interference of some security module, such as SELinux. Is something of the sort active on your box?

    Regards,
    Trantor
    ZeXtras Website # ZeXtras Wiki # ZeXtras Store

    ZeXtras System Administrator and Installer Guru

  4. #4
    Active Member
    Join Date
    May 2013
    Posts
    10
    Hi

    OK, all sorted

    Had to update the vbox additions to the latest version (doh!)

    Then used

    mount -t vboxsf zbackup -o rw,dmode=777,gid=501,uid=500 /opt/zimbra/backup/

    where zbackup was the transient R/W folder assigned to the VM from the host OS through Virtualbox shared folder system

    gid / uid are the respective ids for the zimbra user on the VM

    The initialisation pass is now currently running and I can see the data on the SATA disk on the host OS

    Next up is to get a sample backup done and see what folders I need to write to tape so we have a full backup system implemented

    Thanks for your help, sorry it was my bad!
    d0s0n likes this.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •