Unable to edit user accounts after updating to ZeXtras Suite 1.8.0
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Unable to edit user accounts after updating to ZeXtras Suite 1.8.0

  1. #1
    Active Member
    Join Date
    Jun 2012
    Location
    Verona, Italia
    Posts
    12

    Exclamation Unable to edit user accounts after updating to ZeXtras Suite 1.8.0

    Hi at all,
    I've update my Zimbra Open Source Ed. at work from Rel. 7.1.1 to 7.2.2 without apparently issue last night.
    Machine is CentOS 5.9 (x86). Zimbra has 35 account and i can't access to 'Modify' tab on every users now.
    Error is "JavaScript error encountered in method ZaAccountViewController.prototype._setView".
    I' ve installed 'zeXtras suite' for testing 'mobile' part.


    Thank you.
    Luciano.

  2. #2
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,356
    Hello Luciano,
    welcome to the forums!

    In order to help you I need to know your ZeXtras Suite version. It would be of great help if you could access the Zimbra Administration Console adding "?dev=1" at the end of your URL (e.g. https://mail.yourdomain.com:7071/?dev=1) and see if the error still appears.
    If so, please open your browser's developer tools ("Developer Tools" on Google Chrome or "Firebug" in Firefox) and paste here any error you can find in the Console.

    Have a nice day,
    Cine

  3. #3
    Active Member
    Join Date
    Jun 2012
    Location
    Verona, Italia
    Posts
    12
    Quote Originally Posted by Cine View Post
    Hello Luciano,
    welcome to the forums!

    In order to help you I need to know your ZeXtras Suite version. It would be of great help if you could access the Zimbra Administration Console adding "?dev=1" at the end of your URL (e.g. https://mail.yourdomain.com:7071/?dev=1) and see if the error still appears.
    If so, please open your browser's developer tools ("Developer Tools" on Google Chrome or "Firebug" in Firefox) and paste here any error you can find in the Console.

    Have a nice day,
    Cine
    Hi Cine,
    I' ve start chrome with : ?dev=1 but on details nothing appears. Firefox get
    "Riscontrato errore JavaScript in method ZaAccountViewController.prototype._setView fileName: https://pop.xxxxxxx.xxxxxx.it:7071/z...v=121204215413 lineNumber: 179 columnNumber: 2"

    More ...
    I' ve noted in mailbox.log this issue on same time:
    2013-01-22 17:22:52,527 ERROR [btpool0-31://pop.xxxxxx.xxxxxx.it:7071/service/admin/soap/zextras] [name=admin@xxxxx.xxxxx.it;mid=2;ip=172.19.1.11;ua= ZimbraWebClient - GC24 (Win);] extensions - Can not read/write file: /opt/zimbra/backup/zextras/accounts/b6f5277d-3201-47b3-a9ea-7eee5fbb6a46/backupstat
    at com.zextras.lib.ZxFileStats.<init> ( ZxFileStats.java:44 )
    at com.zextras.backup.ZEBackupStats.<init> ( ZEBackupStats.java:100 )
    at com.zextras.backup.papi.GetAccountBackupInfoHandle r.handle ( GetAccountBackup
    ....

    More ...
    On Admin account i' ve be able to 'modify' account ... strange.

    I've download and install Zextras Suite 1.8.0 yesterday.


    Thank you.
    L.
    Last edited by lucianog; 01-22-2013 at 05:05 PM.

  4. #4
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,356
    Hello Luciano!

    I moved your posts to a separate thread with a proper title to help any other user find this information...

    The issue you are experiencing is caused by a bug in the ZeXtras Administration Zimlet.
    The bug has already been fixed, please download THIS ZIMLET FILE and deploy it on your server (either through the Zimbra Administration Console or the Zimbra CLI).


    I take this opportunity to inform all users that the fix has also been pushed to production tree and included in the downloadable ZeXtras Suite package.
    No need to install this version of the Zimlet if you are not experiencing the very same issue.


    Have a nice day,
    Cine

  5. #5
    Active Member
    Join Date
    Jun 2012
    Location
    Verona, Italia
    Posts
    12
    Hi Cine,
    Fantastic! I' ve (You) Resolved!

    Thank You.
    Luciano.

  6. #6
    Active Member
    Join Date
    Jan 2013
    Posts
    17
    Hi Luciano and Cine, i'm from italy too and had the very same issue since yesterday when i'v updated the zextras module to 1.8.0, the only difference is that i can edit all the old account but not the newest, to be able to edit also the newest i need to whait 24h ( think it depends on the smart scan backup running every night and enable the new account correctly), i'v try the zextras version posted here but problem persist, suggestion are very appreciated!

  7. #7
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,356
    Hello blissard,
    welcome to the forums!

    If you updated the ZeXtras Administration Zimlet chances are that some old .js data is stored in your browser's cache...
    Did you try accessing the Zimbra Admin Console adding "?dev=1" to the URL? This forces the browser to ignore any cached data and to reload all .js files one by one, if the UI behaves correctly this way then you only need to clear your browser's cache to permanently fix the issue...

    Have a nice day,
    Cine

  8. #8
    Active Member
    Join Date
    Jan 2013
    Posts
    17
    Quote Originally Posted by Cine View Post
    Hello blissard,
    welcome to the forums!

    If you updated the ZeXtras Administration Zimlet chances are that some old .js data is stored in your browser's cache...
    Did you try accessing the Zimbra Admin Console adding "?dev=1" to the URL? This forces the browser to ignore any cached data and to reload all .js files one by one, if the UI behaves correctly this way then you only need to clear your browser's cache to permanently fix the issue...

    Have a nice day,
    Cine
    Thank you!!! It works!!!

  9. #9
    Active Member
    Join Date
    Jan 2013
    Posts
    5
    I am having a related issue since I updated to version 1.8.0. I am running the latest 64 bit version 8 of Zimbra Open Source edition, OS is Ubuntu 10.04.3

    I can't open the admin consol, it gets to the "loading" dialog and hangs. I have cleared the browser cache, opened up the developer consol in Firefox, loaded the admin url with the "?dev=1" switch.

    I received the following error message:-

    [12:19:23.198] TypeError: ZaController.initPopupMenuMethodsZaAccountListCont roller is undefined @ https://xxx.xxx.xxx.xxx:7071/service...1105171432:572

    Any assistance would be greatly appreciated.

  10. #10
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,356
    Hello nicko,
    welcome to the forums!

    We found out this issue earlier this morning (we had a hard time reproducing it) and prepared a fixed ZeXtras Administration Zimlet file. Please download it and deploy it to your server, this should solve the issue.

    As usual, the fix has been pushed to the production tree and included in the ZeXtras Suite package.

    Have a nice day,
    Cine
    the ZeXtras Team

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •