ZeXtras ZxAdmin Notification, DoMonthlyReportOperation failed.
Results 1 to 10 of 10
Like Tree1Likes
  • 1 Post By simon

Thread: ZeXtras ZxAdmin Notification, DoMonthlyReportOperation failed.

  1. #1
    Active Member
    Join Date
    Dec 2012
    Location
    Denver, Colorado, USA
    Posts
    9

    ZeXtras ZxAdmin Notification, DoMonthlyReportOperation failed.

    Greetings. I received the following email from a Zimbra server we maintain which is a "first". A search on Google and through this forum did not return any immediate hits (though I could have over looked something as well). Please do note that the "Operation Host" has been altered to "mail.example.com" for client privacy concerns.

    The Zimbra server is Ubuntu 10.04LTS, 64-bit for reference.

    Code:
    This is an automated notification from ZxAdmin about DoMonthlyReportOperation.
    
    Operation DoMonthlyReportOperation failed.
    
    Operation Id: 72b92e23-001b-4dd5-a22e-8e8d1322b53c
    Operation Host: mail.example.com
    
    
    Scheduled operation
    
    ZeXtras Version: 1.8.8
    ZeXtras commit: c67118a55a1304ade1f2a2f51707290b6f5058c2
    Zimbra version: 7.2.4_GA_2900 20130523111005 20130523-1114 FOSS
    
    Error: No logs found to build the report
    This system has been running ZeXtras Suite since v1.2.11 days (trying to recall when ZxAdmin came out relative to the other additional modules though like ZxBackup and ZxMobile), and as noted above, this is a first time message seeing such. I admit the issue seems a bit obvious as to the source and root of the cause. However, I would like to know how to resolve such since I am not aware of how or where ZxAdmin generates this type of report, let alone that ZxAdmin could do and actually does such (which is indeed appreciated). Would this be related potentially to the "Daily Mail Reports" as well (I believe these are generated by Zimbra directly) and a variant of said reports?

    Feedback and questions are welcomed. Thanks in advance.

  2. #2
    ZeXtras Ex-Employee
    Join Date
    Oct 2012
    Location
    Vicenza
    Posts
    14
    Hi LinuxETC,
    To see where the logs are stored, type the following command:


    Code:
    zxsuite admin getProperty ZxAdmin_AdminLogPath

    The logs are saved in files with the name format 'yyyy_mm', while the reports are saved in files by the same name but with the '.report' extention.
    That error message might be caused by a lack of log files in such directory.
    The report generation operation executes automatically once a day, trying to generate a report for the previous month, but performs no operations if the report file is already present.
    What this means is that usually the first day of every month a report will be created and sent to the administrators.
    If you with to re-create an already existing report you can use the following command:


    Code:
    zxsuite admin doMonthlyReport month 04/2013 force true

    Be careful when doing this, because the old report file will be overridden and you might lose some domain-specific data.
    For additional info, you can visit the following link: ZxAdmin Reports and Informations - ZeXtras Suite Wiki
    Hope this clears your doubts.
    Have a good day,
    simon

  3. #3
    Active Member
    Join Date
    Dec 2012
    Location
    Denver, Colorado, USA
    Posts
    9
    Quote Originally Posted by simon View Post
    Hi LinuxETC,
    To see where the logs are stored, type the following command:


    Code:
    zxsuite admin getProperty ZxAdmin_AdminLogPath

    The logs are saved in files with the name format 'yyyy_mm', while the reports are saved in files by the same name but with the '.report' extention.
    That error message might be caused by a lack of log files in such directory.
    Seems this is not the case here since there are reports going back to 2012 at least here (I am guessing the start date of when this system had ZxAdmin installed). There are of the same format of 'yyyy_mm' with '.report' and '.qt' extensions in this directory as you described. The files do have information it seems as well from taking a quick glance at them.

    Perhaps a possible bug if these reports are being generated by ZxAdmin, but the monthly email notification itself is in error?

  4. #4
    ZeXtras Ex-Employee
    Join Date
    Oct 2012
    Location
    Vicenza
    Posts
    14
    Hi LinuxETC,
    would you mind posting the result of an 'ls -l' on the log directory?
    Furthermore, does the command

    Code:
    zxsuite admin getMonthlyReport month 07/2013 local true
    give you a partial report?
    Have a good day,
    simon

  5. #5
    Active Member
    Join Date
    Dec 2012
    Location
    Denver, Colorado, USA
    Posts
    9
    Quote Originally Posted by simon View Post
    Hi LinuxETC,
    would you mind posting the result of an 'ls -l' on the log directory?
    Noted below as requested.

    Code:
    zimbra@example:~/conf/zextras/zxadmin$ ls -lh
    total 144K
    -rw-r----- 1 zimbra zimbra  838 Dec 28  2012 2012_12
    -rw-r----- 1 zimbra zimbra 4.1K Jan 16  2013 2012_12.report
    -rw-r----- 1 zimbra zimbra 2.7K Jan 12  2013 2013_01.report
    -rw-r----- 1 zimbra zimbra  511 Mar  1 06:00 2013_02.report
    -rw-r----- 1 zimbra zimbra  511 Apr  1 06:00 2013_03.report
    -rw-r----- 1 zimbra zimbra  511 May  1 06:00 2013_04.report
    -rw-r----- 1 zimbra zimbra 4.7K May 31 06:00 2013_05.qt
    -rw-r----- 1 zimbra zimbra 4.1K Jun  1 06:00 2013_05.report
    -rw-r----- 1 zimbra zimbra  21K Jun  9 06:00 2013_06.qt
    -rw-r----- 1 zimbra zimbra 4.4K Jul  1 06:00 2013_06.report
    -rw-r----- 1 zimbra zimbra  42K Jul 31 06:00 2013_07.qt
    -rw-r----- 1 zimbra zimbra 4.4K Aug  1 06:00 2013_07.report
    -rw-r----- 1 zimbra zimbra 4.8K Aug  2 06:00 2013_08.qt
    Quote Originally Posted by simon View Post
    Furthermore, does the command

    Code:
    zxsuite admin getMonthlyReport month 07/2013 local true
    give you a partial report?
    A portion is noted below (domains have been "santized" for privacy reasons accordingly):
    Code:
    zimbra@mail002:~/conf/zextras/zxadmin$ zxsuite admin getMonthlyReport month 07/2013 local true
    
    ** GLOBAL REPORT **
    
    No admin logins in the specified month!
    No admin activity in the specified month!
    Total accounts: 24
    
    
    ** DOMAIN REPORT **
    
    Domain: example001.com
    Last admin login: no logins in the specified month
    Account/max accounts: 5/5
    Current Domain Size: 417 MB
    Maximum Domain Size: Unlimited
    Accounts with no quota limit: 5
    Total size of accounts with no quota limit: 417 MB
    System Resources in the domain: 0
    Calendar Resources in the domain: 1
    Successful domain actions: 0
    Unsuccessful domain actions: 0
    
    Domain: example002.com
    Last admin login: no logins in the specified month
    Account/max accounts: 9/Unlimited
    Current Domain Size: 2 GB
    Maximum Domain Size: Unlimited
    Accounts with no quota limit: 9
    Total size of accounts with no quota limit: 2 GB
    System Resources in the domain: 0
    Calendar Resources in the domain: 0
    Successful domain actions: 0
    Unsuccessful domain actions: 0
    
    <...snipped...>
    
    ** ADMIN REPORT **
    
    Local System Accesses: 0
    There is an error on the Admin notes since there has been a few "admin" logins (myself in particular first hand) via the Zimbra Admin Console web UI panel, but aside from that it is accurate looking.

  6. #6
    ZeXtras Ex-Employee
    Join Date
    Oct 2012
    Location
    Vicenza
    Posts
    14
    Hi LinuxETC,
    from the 'ls -l' I see that the only log file you have is '2012_12'. The others are the reports, and the quota (.qt) files.
    First of all, could you check if the admin logging is enabled by executing this command?

    Code:
    zxsuite admin getProperty ZxAdmin_AdminLogEnabled
    If this value is set to false, you need to enable logging with the following:

    Code:
    zxsuite admin setProperty ZxAdmin_AdminLogEnabled true
    If the logging is already enabled, ZeXtras might have problems in writing the log files. Have you ever received a notification with subject "Admin Log Operation Failed, Logging Halted"?
    It might contain useful information to understand why you don't have any logs.
    Have a good day,
    simon

  7. #7
    Active Member
    Join Date
    Dec 2012
    Location
    Denver, Colorado, USA
    Posts
    9
    Quote Originally Posted by simon View Post
    Hi LinuxETC,
    from the 'ls -l' I see that the only log file you have is '2012_12'. The others are the reports, and the quota (.qt) files.
    First of all, could you check if the admin logging is enabled by executing this command?

    Code:
    zxsuite admin getProperty ZxAdmin_AdminLogEnabled
    If this value is set to false, you need to enable logging with the following:

    Code:
    zxsuite admin setProperty ZxAdmin_AdminLogEnabled true
    Simon, this apparently was set to "false". It is now enabled. Thanks for the assistance here as well. I will advise at the end of August if this does resolve this issue or not (I suspect it will).

  8. #8
    ZeXtras Ex-Employee
    Join Date
    Oct 2012
    Location
    Vicenza
    Posts
    14
    Glad to be of help!
    Without waiting a month, if you have a file named '2013_08' in the log path, you're good to go. Also, if you use the Browse Log button in the ZxAdmin tab of the administration zimlet, you should see the recorded admin activity.
    Cheers!
    simon

  9. #9
    Active Member
    Join Date
    Dec 2012
    Location
    Denver, Colorado, USA
    Posts
    9
    Quote Originally Posted by simon View Post
    Glad to be of help!
    Without waiting a month, if you have a file named '2013_08' in the log path, you're good to go.
    That is present. Thanks!

    Quote Originally Posted by simon View Post
    Also, if you use the Browse Log button in the ZxAdmin tab of the administration zimlet, you should see the recorded admin activity.
    Is there some documentation on this section and usage of the ZxAdmin tab? The "Advance" section under "Browser Logs" seems a bit more intuitive than the "Basic" section upon first glance.

    Thanks in advance.

  10. #10
    ZeXtras Ex-Employee
    Join Date
    Oct 2012
    Location
    Vicenza
    Posts
    14
    Quote Originally Posted by LinuxETC View Post
    That is present. Thanks!
    No problem!

    Quote Originally Posted by LinuxETC View Post
    Is there some documentation on this section and usage of the ZxAdmin tab? The "Advance" section under "Browser Logs" seems a bit more intuitive than the "Basic" section upon first glance.
    Unfortunately the documentation on that section is a bit lacking now, I concur. We are working on improving that! In fact, we are actively hiring people

    Quote Originally Posted by LinuxETC View Post
    Thanks in advance.
    My pleasure

    simon
    d0s0n likes this.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •