Problem with Migration 7.1.2 to 7.1.2
Results 1 to 5 of 5

Thread: Problem with Migration 7.1.2 to 7.1.2

  1. #1
    Active Member
    Join Date
    Oct 2011
    Posts
    3

    Problem with Migration 7.1.2 to 7.1.2

    Hi

    I try to migrate from a Zimbra 7.1.2 NE to another 7.1.2 NE with the zextras 1.0.0 migration tool installed on source and zextras suite 1.0.0 installed on destination server

    the export worked fine but importing on the target machine I got through this exception:

    05-Oct-2011 04:01 - Error: ZeXtras ZxBackup Notification, Full Scan failed.

    This is an automated notification from ZxBackup about Full Scan.

    Operation Full Scan failed.

    - exception -
    Unknown Exception
    at com.zextras.backup.ZEFullScanOperation.doOperation (ZEFullScanOperation.java:293)
    at com.zextras.op.ZEOperation.exec(ZEOperation.java:5 84)
    at com.zextras.backup.ZEBackupThread.execOperation(ZE BackupThread.java:194)
    at com.zextras.backup.ZEBackupThread.run(ZEBackupThre ad.java:104)
    Caused by: com.zimbra.common.service.ServiceException: system failure: fetching items of type 5
    ExceptionId:ZxBackup Thread:1317780064142:abb92998171f6763
    Code:service.FAILURE
    at com.zimbra.common.service.ServiceException.FAILURE (ServiceException.java:248)
    at com.zimbra.cs.db.DbMailItem.getByType(DbMailItem.j ava:2134)
    at com.zimbra.cs.mailbox.Mailbox.getItemList(Mailbox. java:2536)
    at com.zimbra.cs.mailbox.Mailbox.getItemList(Mailbox. java:2483)
    at com.zimbra.cs.mailbox.Mailbox.getItemList(Mailbox. java:2479)
    at com.zextras.backup.ZEScanOperation.doItemsScan(ZES canOperation.java:117)
    at com.zextras.backup.ZEScanOperation.doAccountScan(Z EScanOperation.java:86)
    at com.zextras.backup.ZEScanOperation.doDomainScan(ZE ScanOperation.java:50)
    at com.zextras.backup.ZEFullScanOperation.doOperation (ZEFullScanOperation.java:288)
    ... 3 more
    Caused by: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorEx ception: Unknown table engine 'InnoDB'

    Query being executed when exception was thrown:
    SELECT mi.id, mi.type, mi.parent_id, mi.folder_id, mi.index_id, mi.imap_id, mi.date, mi.size, mi.volume_id, mi.blob_digest, mi.unread, mi.flags, mi.tags, mi.subject, mi.name, mi.metadata, mi.mod_metadata, mi.change_date, mi.mod_content FROM mboxgroup8.mail_item AS mi WHERE mailbox_id = 8 AND type IN (5,16)


    at sun.reflect.GeneratedConstructorAccessor85.newInst ance(Unknown Source)
    at sun.reflect.DelegatingConstructorAccessorImpl.newI nstance(DelegatingConstructorAccessorImpl.java:27)
    at java.lang.reflect.Constructor.newInstance(Construc tor.java:513)
    at com.mysql.jdbc.Util.handleNewInstance(Util.java:40 9)
    at com.mysql.jdbc.Util.getInstance(Util.java:384)
    at com.mysql.jdbc.SQLError.createSQLException(SQLErro r.java:1054)
    at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.ja va:3566)
    at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.ja va:3498)
    at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:19 59)
    at com.mysql.jdbc.MysqlIO.sqlQueryDirect(MysqlIO.java :2113)
    at com.mysql.jdbc.ConnectionImpl.execSQL(ConnectionIm pl.java:2568)
    at com.mysql.jdbc.PreparedStatement.executeInternal(P reparedStatement.java:2113)
    at com.mysql.jdbc.PreparedStatement.executeQuery(Prep aredStatement.java:2275)
    at com.zimbra.cs.db.DebugPreparedStatement.executeQue ry(DebugPreparedStatement.java:156)
    at org.apache.commons.dbcp.DelegatingPreparedStatemen t.executeQuery(DelegatingPreparedStatement.java:96 )
    at org.apache.commons.dbcp.DelegatingPreparedStatemen t.executeQuery(DelegatingPreparedStatement.java:96 )
    at com.zimbra.cs.db.DbMailItem.getByType(DbMailItem.j ava:2124)
    ... 10 more


    Does anyone have an idea ?

    Cheers and Thanx in advance!
    Björn

  2. #2
    Active Member
    Join Date
    Oct 2011
    Posts
    3

    upgrade to 1.0.1

    after upgrading to 1.0.1 it worked for one domain

  3. #3
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Hello Björn, and welcome to the forums!

    The log you posted is about a FullScan operation (probably the backup inizialization), not a restore .
    Looks like the problem was actually related to Zimbra..
    Is the destination machine a 6.x machine updated to 7.x? I've seen that error a couple of times, it happened on a couple of updated 7.x machines where I forgot to run the mysql upgrade script..

    Anyway, glad you fixed it
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  4. #4
    Active Member
    Join Date
    Oct 2011
    Posts
    3
    we upgraded one machine (32) from 6.0.3 to 7.1.3 and want to migrate from that one to a fresh install of 7.1.3 / 64
    now we realised that distribution lists don't seem to have been migrated and that the inter mailbox dependencies don't seem to be working...
    what about that mysql script you mentioned? is an upgrade not enough? do we need to do some manual work here?

    Thanx for your help
    Cheers Björn

  5. #5
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Hello Björn,

    the mysql update script (/opt/zimbra/libexec/scripts/migrate20100913-Mysql51.pl) is a Zimbra script that updates all tables and it's needed because Zimbra's MySQL has been upgraded from version 5.0 to 5.1 in 7.x (see Zimbra 7.0 release notes)

    To fix share consistency between mailboxes, see the doCheckShares and doFixShares command on the CLI (run `zxsuite help backup` from a root terminal to see all the options).

    About the distribution lists, that sounds pretty strange.. Can you see any error at the beginning of the import log or in /opt/zimbra/log/mailbox.log? Are the distribution lists in the exported domain?

    Have a nice day,
    Cine
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •