I don't see my email of accounts after migrating
Results 1 to 6 of 6

Thread: I don't see my email of accounts after migrating

  1. #1
    Active Member
    Join Date
    Jan 2013
    Posts
    3

    I don't see my email of accounts after migrating

    Hi friends
    I backup from Zimbra 7.2.0 on centos 5 and the size of backup was 30 G.
    I transfer backup files via rsync command to new server.
    In new server i install centos 6 and zimbra 7.2.2 with different domain from old server.
    In restore backup when i select the backup path and next i see domains and select all and at the next time i don't see any account to restore.
    I replace the backup directory with zextras directory in /opt/zimbra/backup/zextras and run full scan and find accounts.
    but when i restore 200 accounts i don't see any email in mailbox of accounts.

  2. #2
    CTO ZeXtras Employee d0s0n's Avatar
    Join Date
    Apr 2011
    Posts
    565
    Quote Originally Posted by alireza2020 View Post
    Hi friends
    Hi alireza and welcome to the forums.

    Quote Originally Posted by alireza2020 View Post
    I backup from Zimbra 7.2.0 on centos 5 and the size of backup was 30 G.
    I transfer backup files via rsync command to new server.
    In new server i install centos 6 and zimbra 7.2.2 with different domain from old server.
    In restore backup when i select the backup path and next i see domains and select all and at the next time i don't see any account to restore.
    I guess you need to check the permissions on the exported path (on new server), The zimbra user need to read all files.

    Quote Originally Posted by alireza2020 View Post
    I replace the backup directory with zextras directory in /opt/zimbra/backup/zextras and run full scan and find accounts.
    but when i restore 200 accounts i don't see any email in mailbox of accounts.
    you shouldn't do this, the /opt/zimbra/backup/zextras path (default backup path) is used in the restore operation to keep some map files (needed for the ids translations from old to new servers).

    I suggest you to retray from scratch, take a look to these docs:
    Zx Backup: Migration Tool Import - ZeXtras Suite Wiki
    ZxBackup: Incremental migration with ZeXtras Backup - ZeXtras Suite Wiki

    D0s0n
    ZeXtras Website # ZeXtras Wiki # ZeXtras Store

    Head of ZeXtras System Administrators

  3. #3
    Active Member
    Join Date
    Jan 2013
    Posts
    3
    Hi D0s0n and thank for your answer
    I do all of points that you say.
    I set permission with this command:

    $chown zimbra:zimbra /opt/migration

    Is it need to create same domains that are on the old server in new server before restore?

  4. #4
    CTO ZeXtras Employee d0s0n's Avatar
    Join Date
    Apr 2011
    Posts
    565
    Quote Originally Posted by alireza2020 View Post
    Hi D0s0n and thank for your answer
    I do all of points that you say.
    I set permission with this command:

    $chown zimbra:zimbra /opt/migration
    You should add the "-R" switch to set it recursively.

    Quote Originally Posted by alireza2020 View Post
    Is it need to create same domains that are on the old server in new server before restore?
    All domains are created by the import process (as first step), so you don't need to create them before restore. Usually is created first only the domain that corresponds to name of the server (if nedeed).

    D0s0n
    ZeXtras Website # ZeXtras Wiki # ZeXtras Store

    Head of ZeXtras System Administrators

  5. #5
    Active Member
    Join Date
    Jan 2013
    Posts
    3
    Quote Originally Posted by d0s0n View Post
    You should add the "-R" switch to set it recursively.


    All domains are created by the import process (as first step), so you don't need to create them before restore. Usually is created first only the domain that corresponds to name of the server (if nedeed).

    D0s0n
    I set permission to migration before transfer and copy backup files.

    If assume that all of that be correct now why the emails in inbox and sentbox of accounts don't see?

  6. #6
    CTO ZeXtras Employee d0s0n's Avatar
    Join Date
    Apr 2011
    Posts
    565
    Quote Originally Posted by alireza2020 View Post
    I set permission to migration before transfer and copy backup files.
    I said you to check the permission because it is a very common problem, it could depend by transfer method. So even if on the old server the permissions were correct, they could differ on the destination (and not only the base path).

    Quote Originally Posted by alireza2020 View Post
    If assume that all of that be correct now why the emails in inbox and sentbox of accounts don't see?
    If your problem persist we need to know other details about your enviroment and operations output. You should follow the guide lines for reporting posted HERE, expecially the section "Import and Export".

    D0s0n
    ZeXtras Website # ZeXtras Wiki # ZeXtras Store

    Head of ZeXtras System Administrators

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •