Problem installing Migration Tool
Results 1 to 4 of 4

Thread: Problem installing Migration Tool

  1. #1
    Active Member
    Join Date
    Nov 2012
    Posts
    6

    Problem installing Migration Tool

    Hello,

    When I attempt to install the Migration Tool on my server I get the following:

    [root@mail zextras_migration_tool-1.6.2]# ./install.sh all

    -------------------------

    Checking for existing installations ...

    FOUND Zimbra ..

    ./libs/functions.sh: line 82: [: too many arguments
    The current Zimbra installation version doesn't meet the minimum requirements to install ZeXtras successfully.
    Read the minimum requirements for ZeXtras and, if you wish, upgrade Zimbra accordingly.


    Checking my version, I get:

    [zimbra@mail ~]$ zmcontrol -v

    Release CentOS5_64 FOSS edition.


    When I check the version through the GUI (Help Desk > About Zimbra Version) I get: Version 6.0.14_GA_2928.FOSS Aug 2, 2011

    How can I get the CLI to reflect the correct information, so that the tool will install.

    Thank you much,
    Doug

  2. #2
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,360
    Hello Doug!

    the ZeXtras Installer relies on zmprov to identify the Zimbra version running on the server, and zmprov queries the system's package manager about this information. Thus, I'd suggest you to check that all informations about the Zimbra packages are correct in your package manager.

    I asked the devs of the ZeXtras Installer to prepare me a patchfile that will allow you to install ZeXtras Suite regardless of this issue, shouldn't take long to prepare it


    Have a nice day,
    Cine

  3. #3
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,360
    Faster than the speed of light, our good Trantor prepared the attached patch file...

    Apply it by copying it in the zextras_migration_tool-1.6.2 directory and running (as root):
    Code:
    mv zimbra_current_version.txt zimbra_current_version.patch
    patch zimbra_current_version.patch libs/functions.sh
    Run the installer and you should be able to install the ZeXtras Migration Tool!
    Mind that this patch is to be only used in this particular case.


    Have a nice day,
    Cine
    Attached Files Attached Files

  4. #4
    Active Member
    Join Date
    Nov 2012
    Posts
    6
    Cine & Trantor,

    Thank you very much. Of course this system is so jacked up that "patch" is not found on it (although the man page is) and yum is screwed up too, so I can't install it. But, I was able to see what the patch was going to do and did it manually. ZxMig is now installed.

    The journey continues....

    Thanks again,
    Doug

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •