Share email folder doesn't share subfolders - Page 2
Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18
Like Tree2Likes

Thread: Share email folder doesn't share subfolders

  1. #11
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Quote Originally Posted by boumi View Post
    Just had a migration of a customer yesterday evening and the responsible person at the customer is reporting the described problem with subfolders in shares aswell.

    ZeXtras Version is 1.6.2

    So I think I have to get a list of the users and shares with the problem and do

    zmmailbox -z -m user@domain.tld mff "/myfolder" u
    Hello boumi!

    yes, the fix for the issue is the one you posted...

    We are further investigating the issue, I'll update this post as soon as more information are available.


    Have a nice day,
    Cine
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  2. #12
    Active Member
    Join Date
    Nov 2012
    Posts
    6
    I followed the "Incremental migration with ZeXtras Backup", using ZeXtra Suite 1.6.2 to go from CentOS5/Zimbra6.14 to CentOS6/Zimbra7.2.1. The migration of accounts seams to have gone well, but then I noticed this thread before I made the switch. I checked the Shared Folders and they are broke in this same way.

    I have tried the zmmailbox command from the Share source perspective (zmmailbox -z -m sourceuser@myplace.com mff "/Inbox" u) and from the destination perspective (zmmailbox -z -m end.user@myplace.com mff "/sourceuser's Inbox" u), with no apparent change.

    Our company is VERY dependent upon these shares, and if they don't work we will grind to a halt. In my Shares Check report "no mountpoint" is reported 696 times. This is a real show-stopper. Any suggestions on how to move forward on this?

    Is this caused by migrating from 6 to 7, or will this occur during normal operations if I were backing up Zimbra 7 and had to restore to Zimbra 7?

    If I fix this in my current Zimbra 7, will doing the final incremental import corrupt the shares again?

    Thanks for any advise,
    Doug
    Last edited by dlthomas; 11-20-2012 at 03:13 PM.

  3. #13
    Wise Guy Participant
    Join Date
    Apr 2011
    Posts
    34
    Hello Doug.

    I am happy to announce that this particular bug was fixed in version 1.6.3, released yesterday (Changelog - ZeXtras Suite Wiki).
    After having upgraded to version 1.6.3, on the destination server, you need to restart the migration from scratch.
    Namely, you have to return the destination server Zimbra installation to a clean slate and redo the migration process.

    That should allow to migrate everything, shares layout included.

    A good day to you,
    Trantor
    ZeXtras Website # ZeXtras Wiki # ZeXtras Store

    ZeXtras System Administrator and Installer Guru

  4. #14
    Active Member
    Join Date
    Nov 2012
    Posts
    6
    Trantor,

    Thanks for that, I was just going to provide an update that I have downloaded 1.6.3, etc.

    I assumed I would need to bring the source and destination servers to 1.6.3 and redo the export/transfer/import. The export/transfer takes about 10-12 hours. Based on your comments, can I use the 1.6.2 exported data (which I saved in the snapshot before the previous import) for the 1.6.3 import?

    Thanks,
    Doug

  5. #15
    CTO ZeXtras Employee d0s0n's Avatar
    Join Date
    Apr 2011
    Posts
    565
    Don't worry Doug, you can use the 1.6.2 version on the source server, there aren't modifications on exported/backuped files.

    D0s0n
    ZeXtras Website # ZeXtras Wiki # ZeXtras Store

    Head of ZeXtras System Administrators

  6. #16
    Active Member
    Join Date
    Nov 2012
    Posts
    6
    Trantor, D0s0n, & Cine,

    I completed the import with 1.6.3 and did a cursory check of the Shared folders, and it looks like they are operating properly. After the holidays I will do more investigations and determine how we are going to move forward.

    Thank you very much for your prompt attention to this situation.

    Doug
    d0s0n and Zeus like this.

  7. #17
    Member
    Join Date
    Oct 2012
    Posts
    22
    We migrated a zimbra 7.1.2 to a zimbra 8.0.1 with 1.6.3 zextras on both servers, and get this same error.

    When I run the command "backup zxsuite doCheckShares" tells me a lot of errors like this:

    "Account user@domain.tld:
    Folder '/ Inbox' is shared to f5b00707-A776-4ed3-aab8-c8e64e5697a8 (name unknown). However, this account does not exist. "

    I tried running "zmmailbox-z-m user@domain.tld mff" / Inbox "or" but I get nothing.

    Now i'm in production whith new zimbra 8 server! At this point, How I do to renew the shared resources?
    Last edited by s3rgi; 12-05-2012 at 08:03 AM.

  8. #18
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Quote Originally Posted by s3rgi View Post
    We migrated a zimbra 7.1.2 to a zimbra 8.0.1 with 1.6.3 zextras on both servers, and get this same error.

    When I run the command "backup zxsuite doCheckShares" tells me a lot of errors like this:

    "Account user@domain.tld:
    Folder '/ Inbox' is shared to f5b00707-A776-4ed3-aab8-c8e64e5697a8 (name unknown). However, this account does not exist. "

    I tried running "zmmailbox-z-m user@domain.tld mff" / Inbox "or" but I get nothing.

    Now i'm in production whith new zimbra 8 server! At this point, How I do to renew the shared resources?
    Hello s3rgi!

    Can you please tell us precisely what commands you executed? Also, can you please check if shared folders are created with the "i" flag as it happened to the opener of this post?

    Have a nice day,
    Cine
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •