Migration OK but missing mail
Results 1 to 10 of 10

Thread: Migration OK but missing mail

  1. #1
    Active Member
    Join Date
    Jun 2016
    Posts
    5

    Question Migration OK but missing mail

    I migrated from a CentOS 6 Server running the latest patched Zimbra 8.6.
    I migrated to a CentOS 7 Server running the latest patched Zimbra 8.6.
    I now have users that are complaining that they are missing mail. All accounts works great but I am not sure if the error is from the migration or from reading back the backup, is there any way I can fix this? I don't know where to start looking for errors.
    The old server had horrible slow I/O, if that makes any difference.

  2. #2
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,356
    Hello Veidit,
    welcome to the forums!

    The first thing to check would be your restore notifications, as in each of those there's a report about skipped and unrestorable items: more info about this is available in this ZeXtras Wiki page.
    On top of this, the logs in /opt/zimbra/log/ - specifically the restore log and the mailbox.log - include all the information about the restore. If you see any error in there feel free to post it!

    Have a nice day,
    Cine
    the ZeXtras Team

  3. #3
    Active Member
    Join Date
    Jun 2016
    Posts
    5
    Thanks!

    I got this:
    Restored Items: 241538
    Skipped Items: 38
    Unrestored Items: 5

    But I have a lot more complaints then that from users.


    From my Export:
    Operation Export Completed.

    Operation Id: a4d7b1b9-1673-4846-bf5a-3b02a50d6d29
    Operation Host: mail.mydomain.com
    Operation Start Time: 19/06/2016 16:17:14
    Operation Duration: 2 hours, 41 minutes, 3 seconds
    Operation Log path: /opt/zimbra/log/zextras_ZxBackup_doExport_a4d7b1b9-1673-4846-bf5a-3b02a50d6d29.log
    Operation requested by: john@mydomain.com

    ZeXtras Version: 2.2.4
    ZeXtras commit: 5be19157e4950130adb159df3881fba0034707b2
    ZAL Version: 1.10.5
    ZAL commit: 41622f996423af7dc523cdaab77d795aff06304a
    Zimbra version: 8.6.0_GA_1194 20160120153603 20160120-1538 NETWORK(OSE patched)

    Operation requested by: john@mydomain.com

    ZeXtras Version: 2.2.4
    ZeXtras commit: 5be19157e4950130adb159df3881fba0034707b2
    ZAL Version: 1.10.5
    ZAL commit: 41622f996423af7dc523cdaab77d795aff06304a
    Zimbra version: 8.6.0_GA_1194 20160120153603 20160120-1538 NETWORK(OSE patched)

    - stats -
    accounts: 129
    skipped accounts(by COS): 0
    metadata: 242067
    files: 221321
    checked items: 242067
    backup path: /opt/zimbra/backup/export
    skipped items: 0
    I/O read exception: 0
    num skipped files: 0
    items/sec: 25

    So it doesn't match up.
    (I have replaced my domain with mydomain.com here to minimize possible spam)

    Will add another post with the logfiles in a few minutes.

  4. #4
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,356
    Hello Veidit!

    A slight difference between the number of exported and restored items is normal, as there's a number of items that are not restored as those are automatically created when a mailbox is created (all the default folders like /Inbox and /Trash).
    Checking the restore logs in the /opt/zimbra/log/ directory of the destination server will help understanding which items have been skipped and why: feel free to compress the log file(s), upload those on an online file service such as Dropbox or box.com and send me a download link via Private Message...


    Have a nice day,
    Cine
    the ZeXtras Team

  5. #5
    Active Member
    Join Date
    Jun 2016
    Posts
    5
    Thanks. Will do that later today. Thanks for taking your time supporting me who just use your free product!

  6. #6
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,356
    Hello Veidit!

    No problem at all, It's always great to be of assistance

    Have a nice day,
    Cine
    the ZeXtras Team

  7. #7
    Active Member
    Join Date
    Jun 2016
    Posts
    5
    Due to not posting enough I can't see your profile and send you the file

  8. #8
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,356
    Hello Veidit!

    That third post should have done it, if you still can't send PMs please try logging out and then log back in
    Alternatively, feel free to open a support ticket at ZeXtras Support Portal (in this case you'll need to create a ZeXtras Account, valid for the Store as well)

    Have a nice day,
    Cine
    the ZeXtras Team

  9. #9
    Active Member
    Join Date
    Jun 2016
    Posts
    5
    Got any update for me? It seems that your PM-box is full.

  10. #10
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,356
    Hello Veidit!

    Sorry about the full PM mailbox, I've cleared that out... I've checked your logs but couldn't find any specific issue, so I've passed those on to our Devs for further investigation and I'll report back to you as soon as possible...

    Have a nice day,
    Cine
    the ZeXtras Team

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •