[SOLVED] Error after migration...
Results 1 to 8 of 8

Thread: [SOLVED] Error after migration...

  1. #1
    Active Member
    Join Date
    Jan 2012
    Posts
    6

    [SOLVED] Error after migration...

    Hi,

    Last weekend, I did migrate my server from "Release 6.0.13_GA_2918.DEBIAN4.0 DEBIAN4.0 FOSS edition" to the "Release 7.1.4_GA_2555.UBUNTU10_64 UBUNTU10_64 FOSS edition" using "zextras_migration_tool-1.2.2" and "zextras_suite-1.2.2"... After the migration process, I'm receveing the following error when I access the WebConsole Interface (on port 7071):

    Code:
    Ocorreu um erro de JavaScript in method ZaZimbraAdmin.prototype._getLoginMsgPanel 
    fileName: https://10.10.10.8:7071/zimbraAdmin/js/Admin_all.js.zgz?v=120105102944 lineNumber: 24029
    Some of you can help me to solve this issue?

    Thanks,
    Jorge Quintao

  2. #2
    The monkey tester
    Join Date
    Nov 2011
    Posts
    4
    Hi jquintao and welcome to forums,

    - you can get more informations adding "?dev=1" to the URL and see more debug informations into the browser developer console.
    We suggest you Google Chrome (Chrome Developer Tools: Overview - Google Chrome Developer Tools - Google Code).

    Eg (note the ?dev=1 at the end):
    Code:
    https://10.10.10.8:7071/?dev=1
    - have you migrated also the system account (wiki, ham, spam, etc.)?
    - do you try to access with the admin-account of the old server or newer?Or any other user?

    Bests regards
    mrevolution

  3. #3
    Active Member
    Join Date
    Jan 2012
    Posts
    6
    Hi Mr.Evolution,

    When I try use Chrome Developer Tools, I can see:

    Code:
    :7071/service/zimlet/com_zimbra_adminversioncheck/com_zimbra_adminversioncheck.js?v=120105102944:17Start loading com_zimbra_adminversioncheck.js
    :7071/service/zimlet/com_zimbra_cert_manager/ZaCert.js?v=120105102944:1Loaded ZaCert.js
    :7071/service/zimlet/com_zimbra_cert_manager/ZaCertView.js?v=120105102944:1Loaded ZaCertView.js
    :7071/service/zimlet/com_zimbra_cert_manager/ZaCertViewController.js?v=120105102944:1Loaded ZaCertViewController.js
    :7071/service/zimlet/com_zimbra_cert_manager/zimbra_cert.js?v=120105102944:1Loaded zimbra_cert.js
    https://10.10.10.8:7071/service/admin/soap/GetFolderRequestFailed to load resource: the server responded with a status of 500 (Internal Server Error)
    The old server is working fine... These errors don't occur in the old server... In the new server, this errors occurs using any user with administrative rights... The message appears only in the admin console... I can see an error too when I try access Domains/netsol.com.br (my domain)... The error is:

    Code:
    A conta não existe Mensagem: no such account: wiki@netsol.com.br Código de erro: 
    account.NO_SUCH_ACCOUNT Method: [unknown] Detalhes:soap:Sender
    The Chrome Console displays:

    Code:
    POST https://10.10.10.8:7071/service/admin/soap/GetFolderRequest 500 (Internal Server Error)
    AjxRpcRequest.invokeAjxRpcRequest.js:134
    AjxRpc.invokeAjxRpc.js:86
    ZmCsfeCommand.invokeZmCsfeCommand.js:262
    ZaDomain.loadNotebookACLsZaDomain.js:1707
    ZaItem.loadZaItem.js:420
    ZaOverviewPanelController.domainTreeListenerZaOverviewPanelController.js:733
    ZaOverviewPanelController._overviewTreeListenerZaOverviewPanelController.js:700
    AjxCallback.runAjxCallback.js:94
    AjxListener.handleEventAjxListener.js:52
    AjxEventMgr.notifyListenersAjxEventMgr.js:67
    DwtControl.notifyListenersDwtControl.js:552
    DwtTree._notifyListenersDwtTree.js:502
    DwtTree._itemClickedDwtTree.js:423
    DwtTreeItem._mouseUpListenerDwtTreeItem.js:925
    AjxCallback.runAjxCallback.js:94
    AjxListener.handleEventAjxListener.js:52
    AjxEventMgr.notifyListenersAjxEventMgr.js:67
    DwtControl.notifyListenersDwtControl.js:552
    DwtControl.__mouseEventDwtControl.js:3141
    DwtControl.__processMouseUpEventDwtControl.js:3005
    DwtControl.__mouseUpHdlrDwtControl.js:2912
    The old zimbra server has the wiki@netsolbox.com.br account, with an alias wiki@netsol.com.br... But this domain wasn't imported, and this account isn't in the new server...

    How can I fix this issue?

    Can you help me?

    Thanks,
    Jorge Quintao

    Quote Originally Posted by mr.evolution View Post
    Hi jquintao and welcome to forums,

    - you can get more informations adding "?dev=1" to the URL and see more debug informations into the browser developer console.
    We suggest you Google Chrome (Chrome Developer Tools: Overview - Google Chrome Developer Tools - Google Code).

    Eg (note the ?dev=1 at the end):
    Code:
    https://10.10.10.8:7071/?dev=1
    - have you migrated also the system account (wiki, ham, spam, etc.)?
    - do you try to access with the admin-account of the old server or newer?Or any other user?

    Bests regards
    mrevolution

  4. #4
    Active Member
    Join Date
    Jan 2012
    Posts
    6
    Hi,

    I try create the user wiki@netsol.com.br to solve this issue... Now, the error changed to:

    Ocorreu um erro no servidor Mensagem: no such folder id: 12 Código de erro:
    mail.NO_SUCH_FOLDER Method: [unknown] Detalhes:soap:Sender
    The Chrome Console displays:

    POST https://10.10.10.8:7071/service/admi...tFolderRequest 500 (Internal Server Error)
    AjxRpcRequest.invokeAjxRpcRequest.js:134
    AjxRpc.invokeAjxRpc.js:86
    ZmCsfeCommand.invokeZmCsfeCommand.js:262
    ZaDomain.loadNotebookACLsZaDomain.js:1707
    ZaItem.loadZaItem.js:420
    ZaOverviewPanelController.domainTreeListenerZaOver viewPanelController.js:733
    ZaOverviewPanelController._overviewTreeListenerZaO verviewPanelController.js:700
    AjxCallback.runAjxCallback.js:94
    AjxListener.handleEventAjxListener.js:52
    AjxEventMgr.notifyListenersAjxEventMgr.js:67
    DwtControl.notifyListenersDwtControl.js:552
    DwtTree._notifyListenersDwtTree.js:502
    DwtTree._itemClickedDwtTree.js:423
    DwtTreeItem._mouseUpListenerDwtTreeItem.js:925
    AjxCallback.runAjxCallback.js:94
    AjxListener.handleEventAjxListener.js:52
    AjxEventMgr.notifyListenersAjxEventMgr.js:67
    DwtControl.notifyListenersDwtControl.js:552
    DwtControl.__mouseEventDwtControl.js:3141
    DwtControl.__processMouseUpEventDwtControl.js:3005
    DwtControl.__mouseUpHdlrDwtControl.js:2912
    I believe that the user wiki was being used to the service notebook, and this service doesn't exist in the new server (7.x version)...

    Thanks,
    Jorge Quintao

  5. #5
    Active Member
    Join Date
    Jan 2012
    Posts
    6
    Hi,

    I try export the domain netsolbox.com.br using the ZxMigration Tool e import in the new server... When I exported, the only one account was wiki@netsolbox.com.br (with the alias wiki@netsol.com.br)... When I try import in the new server, I received the following notification:

    30-Jan-2012 18:57 - Information: ZeXtras ZxBackup Notification, External Restore completed.

    This is an automated notification from ZxBackup about External Restore.

    Operation External Restore Completed.

    Operation Id: 5cfd2596-ecde-402a-b600-15b152d7abc6
    Operation Host: netsol.share.netsol.com.br
    Operation Log path: /opt/zimbra/log/zextras_ZxBackup_ExternalRestore_5cfd2596-ecde-402a-b600-15b152d7abc6.log


    Warnings: 0
    Errors: 0


    - notes -
    null

    - skipped items -
    More about unrestorable items: ZxBackup Troubleshooting - ZeXtras Suite Wiki

    account wiki@netsolbox.com.br search query: item: 436,424,427,419
    And the error continues when I try access Domain/netsol.com.br:

    Ocorreu um erro no servidor Mensagem: no such folder id: 12 Código de erro:
    mail.NO_SUCH_FOLDER Method: [unknown] Detalhes:soap:Sender
    Thanks,
    Jorge Quintao

  6. #6
    CTO ZeXtras Employee d0s0n's Avatar
    Join Date
    Apr 2011
    Posts
    565
    You're right, the problem is the Notebook account, a removed features in Zimbra 7.

    To solve your problem you need to remove the reference to the old Notebook account from the domain: zimbraNotebookAccount property with the command:

    Code:
    zmprov md netsol.com.br zimbraNotebookAccount ""
    Any feedback is welcome.

    D0s0n
    ZeXtras Website # ZeXtras Wiki # ZeXtras Store

    Head of ZeXtras System Administrators

  7. #7
    Active Member
    Join Date
    Jan 2012
    Posts
    6
    Hi D0s0n,

    Thanks... Your command works fine... I'm trying change the admin password with the command:

    zmprov sp admin@netsol.com.br password
    But I received the following message:

    ERROR: service.FAILURE (system failure: change password listener zxmobileListener for account admin@netsol.com.br not found)
    Can you help me?

    Thanks,
    Jorge Quintao

  8. #8
    CTO ZeXtras Employee d0s0n's Avatar
    Join Date
    Apr 2011
    Posts
    565
    I've checked your problem with dev team, it seems to be another little difference between Zimbra 6.x and 7.x versions.

    On Zimbra 6.x, ZxMobile need to modify the default change password listener for to keep informed about "changing password" and this attribute is exported by zxmig and correctly reimported on new servers. But on Zimbra 7.x this attribute is not needed. So you need to unset the "zimbraPasswordChangeListener" domain attribute with this command:

    Code:
    zmprov md netsol.com.br zimbraPasswordChangeListener ""
    In the next versions we'll try to correct this behaviour on import.

    Thanx for your input,
    D0s0n
    ZeXtras Website # ZeXtras Wiki # ZeXtras Store

    Head of ZeXtras System Administrators


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •