Problem after installation of 1.8.13 - Kernel too old message
Results 1 to 9 of 9

Thread: Problem after installation of 1.8.13 - Kernel too old message

  1. #1
    Active Member
    Join Date
    Mar 2014
    Posts
    5

    Problem after installation of 1.8.13 - Kernel too old message

    Hi,

    I've just tried to install Zextras Suite 1.8.13 on my Zimbra 7.2.6 server running on CentOS 5.10.

    The installation seems to go fine, no errors during the installation. A mail is sent to my account stating "Backup path not initialized: your storage backup device could be unmounted", but that's it.

    When I try to run "zxsuite core getVersion", the following comes as output:

    Code:
    FATAL: kernel too old
    /opt/zimbra/bin/zxsuite: line 54: 26988 Segmentation fault      NAILGUN_PID= /opt/zimbra/bin/ng com.zextras.zxcli.ZxSuiteCLI --columns 104 "$@"
    I can't find this referenced anywhere else and I'm wondering if it's in fact my CentOS version that's too old. The installation is updated quite often, so the kernel itself should not be too old.


    Best regards,
    Frode.

  2. #2
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    ZeXtras Suite 1.8.13 Hotfix 1 has been released!

    This release adds the following fixes to ZeXtras Suite 1.8.13:
    * Added a connection throttling system to the ZeXtras Administration Zimlet in order to lower the number of connections per second thus making it less probable for Zimbra's DoS Filter to kick in.
    * Fixed a dependency issue that could cause the ZeXtras CLI to return a "Kernel Too Old" error.

    If your Zimbra infrastructure is affected by any of those issues, please download the updated package from http://www.zextras.com/zextras-download-for-zimbra.html and install it as a standard upgrade.
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  3. #3
    Active Member
    Join Date
    Mar 2014
    Posts
    5
    Excellent!

    I'll try that and report back my findings.

  4. #4
    Active Member
    Join Date
    Mar 2014
    Posts
    5
    After the download of ZeXtras Suite 1.8.13 Hotfix 1 the installation of ZeXtras Core went without problem, no "Kernel Too Old" error.

    The Zimlet part of the installation now fails with this status:

    Code:
    Zimlet installation failed. Exiting.
    .......
    The Zimlet installation has failed. That might be due to an incomplete startup
    of the Zimbra webapp. Please verify Zimbra is up and running, then retry
    the deployment of the zimlet with ./install.sh zimlet  .
    .......
    I've checked that the Zimbra webapp is up and running and I've also booted the server to be sure that everything comes back up. Zimbra is working for my users so everything is good on that side.

  5. #5
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Hello FrodeS!

    Could you please send the relevant mailbox.log part to community@zextras.com so that we'll be able to see why the Zimlet install failed?

    Have a nice day,
    Cine
    the ZeXtras Team
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  6. #6
    Active Member
    Join Date
    Mar 2014
    Posts
    5
    Hi Cine,

    Thanks for your quick response. The mailbox.log parts has been sent per e-mail.


    Best regards,
    FrodeS

  7. #7
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Hello FrodeS!

    It looks like the Zimlet installation fails because of a permission issue (like the one discussed HERE). Running zimbra's permission fix tool, `zmfixperm`, should solve the issue.

    Have a nice day,
    Cine
    the ZeXtras Team
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  8. #8
    Active Member
    Join Date
    Mar 2014
    Posts
    5
    Hi Cine,

    I've just fixed the permissions and re-run the Zimlet install. That didn't make it properly through to the Zimbra Admin web, so I then uninstalled the Zimlet part (./install.sh -u zimlet) and then re-run the installation again and then it worked as a charm.

    Thank you very much for your help!

    Best regards,
    FrodeS.

  9. #9
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    You're welcome!

    Have a nice day,
    Cine
    the ZeXtras Team
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

LinkBacks (?)

  1. 03-10-2014, 10:46 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •