[SOLVED]Mail:Parent must be a subclass of Composite Fehlercode: -1 Method: DwtControl - Page 2
Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: [SOLVED]Mail:Parent must be a subclass of Composite Fehlercode: -1 Method: DwtControl

  1. #11
    CTO ZeXtras Employee d0s0n's Avatar
    Join Date
    Apr 2011
    Posts
    570
    Hi,
    we are investigating the "new" problem, maybe caused by the hurry, I'll post here as soon as the Dev team gives me feedback.

    In the meantime you can use the 'zxmig' Command Line Interface to export your data, as Cine said in his replay yesterday.

    Bye bye

    D0s0n
    ZeXtras Website # ZeXtras Wiki # ZeXtras Store

    Head of ZeXtras System Administrators

  2. #12
    Active Member
    Join Date
    Sep 2011
    Posts
    7
    Hi d0s0n,

    thanks for your help. I'm now on the way to drill down our 2 mbs to 1 mbs with the hope your mig-tool works.

    On the other hand i've a complete installation of ZCS 7.1.2 NE with only one mbs in standby. this is the mig-destinationen. For testing i made snapshots of the vm and installed your tool. And it works (with one mbs) with testdomains and accounts.

    So we'll see, who is faster....me with reconfiguring our mailservers or you with a working solution for multi-mbs versions

    On that way many thanks for your fast answers and help. And if you need more logs for problemsolving, give me an info.

  3. #13
    CTO ZeXtras Employee d0s0n's Avatar
    Join Date
    Apr 2011
    Posts
    570
    The problem is only about UI (zimlet), but the tool is fully functional on your system, even with 2 mail-store servers, so you can export all your data with this command as zimbra user, on each store servers (on separated folders):
    Code:
    zxmig --progress migration doExport /export_dir
    or if you want to export only specific domains, you can try this:
    Code:
    zxmig --progress migration doExport /export_dir domains <domain1>,<domain2>,...
    After export you can import data with ZxBackup, a module of ZeXtras Suite.

    Quote Originally Posted by chefkoch009 View Post
    So we'll see, who is faster....me with reconfiguring our mailservers or you with a working solution for multi-mbs versions
    Sorry about that, but to solve this problem I need to set up a dedicated test enviroment. Tomorrow it will be solved surely, but you can do your migration without wait us, as described above. So who has won?
    ZeXtras Website # ZeXtras Wiki # ZeXtras Store

    Head of ZeXtras System Administrators

  4. #14
    Active Member
    Join Date
    Sep 2011
    Posts
    7
    hi d0s0n,

    thanks for your reply. I think the CLI-way will works, but at 1st i tried the "easy going clicking way".

    And that's why you won.

    But for now I've one more question: if i exported all domains with your tool, i'll be able to choose on the destination (other ZCS version an already defined domains and aliases) if the import is a domain or an domainalias?

    bye bye
    chefkoch009

  5. #15
    CTO ZeXtras Employee d0s0n's Avatar
    Join Date
    Apr 2011
    Posts
    570
    Quote Originally Posted by chefkoch009 View Post
    But for now I've one more question: if i exported all domains with your tool, i'll be able to choose on the destination (other ZCS version an already defined domains and aliases) if the import is a domain or an domainalias?
    The import procedure follows the steps documented on our wiki, when you start the import you can chose what domains and what accounts to import, even if they allready exist on destination system, but the attributes will be restored as on the origin system.

    See you tomorrow...
    ZeXtras Website # ZeXtras Wiki # ZeXtras Store

    Head of ZeXtras System Administrators

  6. #16
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,364
    Quote Originally Posted by d0s0n View Post
    Tomorrow it will be solved surely, but you can do your migration without wait us, as described above. So who has won?
    As our superCTO promised (you know, he's the one with the whip ) we updated the ZeXtras Migration Tool and ZeXtras Suite packages on the website with the fix for this bug.
    Please unpack (as root) the newly downloaded file on your server and run the following commands to manually deploy the fixed zimlet with ./install.sh zimlet


    Enjoy!

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •