Problem auto starting. 9.0.0 ZEXTRAS and CentOS 8
Results 1 to 3 of 3

Thread: Problem auto starting. 9.0.0 ZEXTRAS and CentOS 8

  1. #1
    Junior Member
    Join Date
    Dec 2020
    Posts
    2

    Problem auto starting. 9.0.0 ZEXTRAS and CentOS 8

    9.0.0 ZEXTRAS and CentOS 8 Linux (4.18.0-193.28.1.el8_2.x86_64)
    It has problem auto starting. (Two cases of installation from scratch)

    Code:
    ● zimbra.service - LSB: Zimbra mail service
       Loaded: loaded (/etc/rc.d/init.d/zimbra; generated)
       Active: failed (Result: exit-code) since Tue 2020-12-08 11:43:08 EET; 2min 47s ago
         Docs: man:systemd-sysv-generator(8)
      Process: 1336 ExecStart=/etc/rc.d/init.d/zimbra start (code=exited, status=127)
    
    Dec 08 11:43:08  systemd[1]: Starting LSB: Zimbra mail service...
    Dec 08 11:43:08  zimbra[1336]: /etc/rc.d/init.d/zimbra: line 41: su: command not found
    Dec 08 11:43:08  systemd[1]: zimbra.service: Control process exited, code=exited status=127
    Dec 08 11:43:08  systemd[1]: zimbra.service: Failed with result 'exit-code'.
    Dec 08 11:43:08  systemd[1]: Failed to start LSB: Zimbra mail service.

    Script /etc/rc.d/init.d/zimbra
    line 40,41
    Code:
            # bug 45842
            su - zimbra -c "zmcontrol $1 </dev/null"

    If I change to "/bin/su" in line 41
    Code:
    systemctl status zimbra
    Warning: The unit file, source configuration file or drop-ins of zimbra.service changed on disk. Run 'systemctl daemon-reload' to reload units.
    ● zimbra.service - LSB: Zimbra mail service
       Loaded: loaded (/etc/rc.d/init.d/zimbra; generated)
       Active: failed (Result: exit-code) since Sat 2020-12-05 22:46:47 EET; 15min ago
         Docs: man:systemd-sysv-generator(8)
    
    Dec 05 22:46:47  systemd[1]: Starting LSB: Zimbra mail service...
    Dec 05 22:46:47  zimbra[1345]: /etc/rc.d/init.d/zimbra: line 41: /bin/su: Permission denied
    Dec 05 22:46:47  systemd[1]: zimbra.service: Control process exited, code=exited status=126
    Dec 05 22:46:47  systemd[1]: zimbra.service: Failed with result 'exit-code'.
    Dec 05 22:46:47  systemd[1]: Failed to start LSB: Zimbra mail service.
    -rwsr-xr-x. 1 root root 50448 Apr 24 2020 /bin/su

    Found a similar case here.
    forums zimbra org/ viewtopic.php?f=15&t=68583&p=298599&hilit=startup# p298599
    Last edited by allxi; 12-08-2020 at 05:57 PM.

  2. #2
    Junior Member
    Join Date
    Dec 2020
    Posts
    2
    Im fix'it.

    Delete zimbra.service in /etc/rc.d/init.d/zimbra (# Automatically generated by systemd-sysv-generator)
    and create zimbra.service in /etc/systemd/system/zimbra.service (htt p github.com/Zimbra-Community/zimbra-tools/blob/master/zimbra.service)

  3. #3
    Active Member
    Join Date
    Apr 2020
    Posts
    7

    RE: Centos 8

    On another note you may want to abandon that CentOS 8 install.
    RedHat has pulled the plug on it and it will be EOL ~July 2021.
    It is unknown if CentOS Stream will be worth maintaining but it will
    be more bleeding edge than LTS. The choices of free stable LTS versions
    supported by Zimbra are dwindling

    https://arstechnica.com/gadgets/2020...e-alternatives

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •