Error after Zextras upgrade to 3.0.3
Results 1 to 2 of 2

Thread: Error after Zextras upgrade to 3.0.3

  1. #1
    Junior Member
    Join Date
    Nov 2019
    Posts
    1

    Error after Zextras upgrade to 3.0.3

    Hi,

    during Zextras upgrade to 3.0.3 version from last 2.X version i get an error during zimlet setup

    Code:
    [] INFO: Installing Zimlet com_zextras_zextras on this host.
    java.lang.NoSuchFieldError: READ_UNKNOWN_ENUM_VALUES_USING_DEFAULT_VALUE
            at com.zextras.lib.json.KindObjectMapper.<init>(KindObjectMapper.java:12)
            at com.zextras.lib.json.JSONObject.<clinit>(JSONObject.java:39)
            at com.zextras.modules.admin.cli.DoSetZimletRights.exec(DoSetZimletRights.java:29)
            at com.zextras.zxcli.ZxCLI.execCommand(ZxCLI.java:147)
            at com.zextras.zxcli.ZxCLI.execCommand(ZxCLI.java:127)
            at com.zextras.zxcli.ZxCLI.execCommand(ZxCLI.java:127)
            at com.zextras.zxcli.ZxCLI.mainCLI(ZxCLI.java:104)
            at com.zextras.zxcli.ZxSuiteCLI.main(ZxSuiteCLI.java:12)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
            at java.lang.reflect.Method.invoke(Method.java:498)
            at org.openzal.zal.tools.BootCli.run(BootCli.java:44)
            at org.openzal.zal.tools.ConsoleBoot.main(ConsoleBoot.java:55)

    After then Zextras installation seem broken.

    If I even try to

    Code:
    zxsuite core getVersion
    I get same error


    Code:
    Release 8.7.11.GA.1854.UBUNTU12.64 UBUNTU12_64 FOSS edition, Patch 8.7.11_P14.


    Code:
    Distributor ID: Ubuntu
    Description:    Ubuntu 12.04.5 LTS
    Release:        12.04
    Codename:       precise
    Any ideas ?

  2. #2
    CTO ZeXtras Employee d0s0n's Avatar
    Join Date
    Apr 2011
    Posts
    571
    Hi Daniele, welcome to our forums!

    I never saw an error like this, can you provide the mailbox.log? (expecially during the mailboxd service restart and zextras extension boot)

    When you do the getVersion command, did you see just the error or something else?
    Are you using other zimbra extensions?

    Have a nice day
    ZeXtras Website # ZeXtras Wiki # ZeXtras Store

    Head of ZeXtras System Administrators

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •