team android no connection
Results 1 to 10 of 10

Thread: team android no connection

  1. #1
    Junior Member
    Join Date
    Aug 2019
    Posts
    1

    team android no connection

    HI,

    we try to connect with android team apps but we have always the same error.
    After login,password,server, apps start downloading conversations and we have this error :

    Something gone wrong!

    Value <!DOCTYPE of type java.lang.String cannot be converted to JSONObject.

    thanks in advance for any idea.

    Have a good day.

    PS : android phone LG G6 android version 8.0.0

    i have to connection with Drive Apps no problem of connection for this apps

  2. #2
    Junior Member
    Join Date
    Aug 2019
    Posts
    1
    Hi,

    I have the same problem.

  3. #3
    Active Member
    Join Date
    Dec 2012
    Posts
    13
    same issue for me.

  4. #4
    Gil
    Gil is offline
    Moderator Participant
    Join Date
    Sep 2019
    Posts
    24
    You should check some configuration parameters on your Zimbra host.
    In the Web administration panel under "Configure" -> "Domains" -> "$your domain"
    you should see three values:

    Public Service Host Name
    Public Zimbra Public Protocol
    Public Zimbra Public Port

    They should be valorized as

    $yourhostname
    https
    443

    It is also possible to use the command line:

    zmprov gd $yourdomain zimbraPublicServiceHostname zimbraPublicServicePort zimbraPublicServiceProtocol

    to get the values and

    zmprov md $yourdomain zimbraPublicServiceHostname $yourpublicfqdn zimbraPublicServicePort 443 zimbraPublicServiceProtocol https

    to set them
    Gil - Zextras Technical Support Engineering
    https://support.zextras.com

  5. #5
    Gil
    Gil is offline
    Moderator Participant
    Join Date
    Sep 2019
    Posts
    24
    Hello Sirusa,

    have you tried restarting the zimbra services after editing the domain settings?
    Also Team makes use of websockets so if you have a reverse proxy between the Zimbra host and the public network it must be configured accordingly.
    Gil - Zextras Technical Support Engineering
    https://support.zextras.com

  6. #6
    Active Member
    Join Date
    Dec 2012
    Posts
    13
    Quote Originally Posted by Gil View Post
    Hello Sirusa,

    have you tried restarting the zimbra services after editing the domain settings?
    Also Team makes use of websockets so if you have a reverse proxy between the Zimbra host and the public network it must be configured accordingly.
    we have a reverse proxy, so what do you mean "configured accordingly" ?
    it doesn't work for me, no way to got video or sound working from remote site, on on-premise works.
    By this time of corona virus everyone is working remotely, so it a pain now not to have these features.

  7. #7
    Gil
    Gil is offline
    Moderator Participant
    Join Date
    Sep 2019
    Posts
    24
    Quote Originally Posted by dominix View Post
    we have a reverse proxy, so what do you mean "configured accordingly" ?
    it doesn't work for me, no way to got video or sound working from remote site, on on-premise works.
    By this time of corona virus everyone is working remotely, so it a pain now not to have these features.
    Hello Dominix,

    we do understand your situation.
    Reverse proxy need some configuration for websocket connections, this is a note for nginx for example but of course it depends on which software is being used.
    Gil - Zextras Technical Support Engineering
    https://support.zextras.com

  8. #8
    Active Member
    Join Date
    Dec 2012
    Posts
    13
    even from inside my LAN, the android app TEAM doesn't connect (error 404)
    no way to get it works.

  9. #9
    Active Member
    Join Date
    Dec 2012
    Posts
    13
    OK, for everyone to understand how this works you have to know one thing.
    Zextras Team do not work like other zimlet, the zimlet is not running inside Zimbra mailbox, but instead the zimlet is inserted into nginx configuration. So you have to use the port managed by the proxy.
    if you're not using the nginx proxy, the Team zimlet is not found (404 error) usually you can not see this 404 error, except when your using the Android Team app by zextras.
    or use a curl test based specially crafted to detect this kind of problem.

    on my site java mailbox process was listening on 443 port and accessed directly by outside's connections, so on this port there is no way for team app to reach Team zimlet.

    But if I forwarded the 443 port from outside to the https nginx ssl port, _or_ if I switched port between mailbox and nginx process the zimlet is suddenly visible.

    So please, be warned to check that your connections from outside do connect to the nginx (+ssl) port for the team zimlet to work.

    cheers to you all.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •