CPU Load 100% on fresh installed ubuntu 16.04 / zimbra 8.8.10 / zextras 2.10.0
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: CPU Load 100% on fresh installed ubuntu 16.04 / zimbra 8.8.10 / zextras 2.10.0

  1. #1
    Member
    Join Date
    Apr 2013
    Posts
    46

    CPU Load 100% on fresh installed ubuntu 16.04 / zimbra 8.8.10 / zextras 2.10.0

    Hello friends,

    cpu load is at 100% but the system has nothing to do (see attachement). the OS has been new installed and has no users yet!
    I can not detect any obvious errors in the log, otherwise everything works just the CPU utilization is much too high! before the
    installation of the zextras the CPU utilization was about 2-5%!

    OS: Ubuntu 16.04.5
    Zimbra: 8.8.10
    Zextras 2.10.0

    any ideas ?
    cheers,
    velvet

    cpu100.jpgcpu100.jpg

    UPDATE: after uninstall zextras the CPU load is back to normal:
    13474 zimbra 20 0 13.176g 2.076g 23080 S 2.3 6.6 0:51.36 java
    Last edited by velvet; 10-12-2018 at 12:33 PM.

  2. #2
    Senior Member
    Join Date
    Oct 2014
    Posts
    78
    Unless I'm mistaken, that output you've posted shows the following:

    Code:
    Percentage of the CPU for user processes (10.1%us)
    
    Percentage of the CPU not used (89.8%id)
    In my book that's 10% busy and 90% idle - are they the figures you're talking about? Is this image supposed to be before or after you installed ZeXtras?
    Regards


    Bill

  3. #3
    Member
    Join Date
    Apr 2013
    Posts
    46
    Quote Originally Posted by phoenix View Post
    Unless I'm mistaken, that output you've posted shows the following:

    Code:
    Percentage of the CPU for user processes (10.1%us)
    
    Percentage of the CPU not used (89.8%id)
    In my book that's 10% busy and 90% idle - are they the figures you're talking about? Is this image supposed to be before or after you installed ZeXtras?
    Yes it is! 90% because of 10 CPUs. yes, the picture is after the installation.
    one CPU of 10 will be used 100% after the installation.

    here without zextras
    https://www.dropbox.com/s/g8a64vi4oj...thout.png?dl=0

    here with zextras
    https://www.dropbox.com/s/it8ypt6aqgl1fl3/with.png?dl=0

    cheers,
    velvet
    Attached Images Attached Images
    Last edited by velvet; 10-12-2018 at 04:41 PM.

  4. #4
    Senior Member
    Join Date
    Oct 2014
    Posts
    78
    I'd suggest that you have too many vCPUs on that server, this is only a test machine isn't it? What virtualization platform are you using? Are you tied to using Ubuntu for this server?

    [EDIT]I forgot to ask how many physical CPUs does this server have?
    Regards


    Bill

  5. #5
    Member
    Join Date
    Apr 2013
    Posts
    46
    test machine?! no matter! that does not explain this increase of a CPU from 3% to 100%

    is KVM with ubuntu 16.04.05 as written in my first post!

    velvet

  6. #6
    Member
    Join Date
    Apr 2013
    Posts
    46
    [EDIT]I forgot to ask how many physical CPUs does this server have?

    it is a vserver from a provider. ok, let's leave that with the CPU, just have a look at the load average.
    it goes from 0.26 to 1.65 after the zextras installation! That's not normal!
    I've been using zextras for years but I have not seen anything like that yet.

    the system does not have to do except zimbra with zextras with zero users!

  7. #7
    Member
    Join Date
    Apr 2013
    Posts
    46
    it looks like the load will come from the realtime scanner!

    I can reproduce it:

    1. install fresh ubuntu 16.04
    2. install zimbra 8.8.10
    3. install zextras 2.10.0
    4. look at the system load (a vcore at 100%)
    5. go to admin gui and turn off the realtime scanner
    6. look again at the sysem load (vcore at 2-4%)
    7. activate the realtime scanner again (system load at the same low)

    restart zimbra - and the vcore is back at 100% until the realtime scanner is switched off!

    cheers,
    velvet

  8. #8
    Junior Member
    Join Date
    Oct 2018
    Posts
    1
    Hello all,

    I have very similar high CPU usage after upgrading to ZeXtras 2.10.0 few days ago. I have only ZxMobile module running, all others including ZxBackup are disabled, therefore I won't expect it to be caused by RealTime Scanner in my case - nevertheless I turn it off via 'zxsuite backup setProperty ZxBackup_RealTimeScanner FALSE' but it did not solve the issue. What I can see in the zmmailboxd.out log is the below every 3-4 seconds:

    2018-10-17 22:34:25.733:INFOejm.ThreadMonitor:Thread-49: Thread 'ZeXtras Suite Real Time Notifier'[RUNNABLE,id:79,cpu:99.54%] SPINNING
    2018-10-17 22:34:25.733:WARNejm.ThreadMonitor:Thread-49:
    org.eclipse.jetty.monitor.thread.ThreadMonitorExce ption: Thread 'ZeXtras Suite Real Time Notifier'[RUNNABLE,id:79,cpu:99.54%] STACK TRACE
    at com.zextras.lib.ZERedologNotifier.readLoop(ZERedologNotifier.java:363)
    at com.zextras.lib.ZERedologNotifier.run(ZERedologNot ifier.java:291)
    at java.lang.Thread.run(Thread.java:748)


    I am not sure if it is the same issue as the one described by velvet, but it at least looks like being very similar. I have no clue how to get this resolved therefore any ideas are more than welcome. The server has less than 10 users with rather low email traffic.

  9. #9
    Junior Member
    Join Date
    Oct 2018
    Posts
    1
    Hello, made a quick account just to give some info on what I discovered about this issue.
    We have two updated Zimbra + Zextras installations: a very small server and a larger one; both had the issue with one core running at 100% all the time after the update. Neither uses zextras backup.

    We discovered that if we turn on the Backup module, let it be active for a few seconds and then disable it again, the CPU usage goes back to normal until the server is restarted.
    There is definitely something wrong with the Backup module, even for servers that don't use it.

    Also, you need to have the RealTimeScanner active for the above fix to work. We tried disabling it via command line on one server and we could not get the CPU usage down no matter how many times we restarted the backup module, until we set the Scanner back to TRUE.

    Here's hoping this helps others with the same issue and here's hoping the Zextras staff finds out what's causing it.

  10. #10
    Active Member
    Join Date
    Jul 2016
    Posts
    4
    Hi All,

    Same issue here! I've been using zimbra and zextras for several years, and after I've upgraded zextras to 2.10.0, the CPU usage increased.
    Here's a chart about my server's CPU load in October:

    mailserver_CPU.jpg

    And here's the output of the top command:
    mailserver_top.jpg

    the pid 2686 is the zmmailboxd java pid

    The zmmailboxd.out logfile is full with the following lines and it receives new lines in every 2 seconds:

    2018-10-25 14:24:35.299:INFO: oejm.ThreadMonitor:Thread-47: Thread 'ZeXtras Suite Real Time Notifier'[RUNNABLE,id:89,cpu:99.42%] SPINNING
    2018-10-25 14:24:35.299:WARN: oejm.ThreadMonitor:Thread-47:
    org.eclipse.jetty.monitor.thread.ThreadMonitorExce ption: Thread 'ZeXtras Suite Real Time Notifier'[RUNNABLE,id:89,cpu:99.42%] STACK TRACE
    at com.zextras.lib.ZERedologNotifier.readLoop(ZERedol ogNotifier.java:363)
    at com.zextras.lib.ZERedologNotifier.run(ZERedologNot ifier.java:291)
    at java.lang.Thread.run(Thread.java:748)
    2018-10-25 14:24:35.300:WARN: oejm.ThreadMonitor:Thread-47:
    org.eclipse.jetty.monitor.thread.ThreadMonitorExce ption: Thread 'ZeXtras Suite Real Time Notifier'[RUNNABLE,id:89,cpu:73.07%] STACK TRACE
    at com.zextras.lib.ZERedologNotifier.readLoop(ZERedol ogNotifier.java:363)
    at com.zextras.lib.ZERedologNotifier.run(ZERedologNot ifier.java:291)
    at java.lang.Thread.run(Thread.java:748)
    2018-10-25 14:24:35.302:WARN: oejm.ThreadMonitor:Thread-47:
    org.eclipse.jetty.monitor.thread.ThreadMonitorExce ption: Thread 'ZeXtras Suite Real Time Notifier'[RUNNABLE,id:89,cpu:73.67%] STACK TRACE
    at com.zextras.lib.ZERedologNotifier.readLoop(ZERedol ogNotifier.java:363)
    at com.zextras.lib.ZERedologNotifier.run(ZERedologNot ifier.java:291)
    at java.lang.Thread.run(Thread.java:748)

    2018-10-25 14:24:37.309:INFO: oejm.ThreadMonitor:Thread-47: Thread 'ZeXtras Suite Real Time Notifier'[RUNNABLE,id:89,cpu:98.42%] SPINNING
    2018-10-25 14:24:37.309:WARN: oejm.ThreadMonitor:Thread-47:
    org.eclipse.jetty.monitor.thread.ThreadMonitorExce ption: Thread 'ZeXtras Suite Real Time Notifier'[RUNNABLE,id:89,cpu:98.42%] STACK TRACE
    at com.zextras.lib.ZERedologNotifier.readLoop(ZERedol ogNotifier.java:363)
    at com.zextras.lib.ZERedologNotifier.run(ZERedologNot ifier.java:291)
    at java.lang.Thread.run(Thread.java:748)
    2018-10-25 14:24:37.310:WARN: oejm.ThreadMonitor:Thread-47:
    org.eclipse.jetty.monitor.thread.ThreadMonitorExce ption: Thread 'ZeXtras Suite Real Time Notifier'[RUNNABLE,id:89,cpu:74.26%] STACK TRACE
    at com.zextras.lib.ZERedologNotifier.readLoop(ZERedol ogNotifier.java:363)
    at com.zextras.lib.ZERedologNotifier.run(ZERedologNot ifier.java:291)
    at java.lang.Thread.run(Thread.java:748)
    2018-10-25 14:24:37.312:WARN: oejm.ThreadMonitor:Thread-47:
    org.eclipse.jetty.monitor.thread.ThreadMonitorExce ption: Thread 'ZeXtras Suite Real Time Notifier'[RUNNABLE,id:89,cpu:73.33%] STACK TRACE
    at com.zextras.lib.ZERedologNotifier.readLoop(ZERedol ogNotifier.java:363)
    at com.zextras.lib.ZERedologNotifier.run(ZERedologNot ifier.java:291)
    at java.lang.Thread.run(Thread.java:748)

    Aside from the high CPU usage, the server works perfectly.

    OS: Ubuntu 16.04 (all upgrades installed)
    Zimbra: 8.8.8_GA_3025.FOSS
    Zextras: 2.10.0 (using ZxMobile only)

    Let me know if you need additional details.
    Last edited by abrahamg; 10-25-2018 at 03:05 PM.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •