Zextras Core Missing after Upgrade to 1.2.5
Results 1 to 7 of 7

Thread: Zextras Core Missing after Upgrade to 1.2.5

  1. #1
    Member
    Join Date
    Jan 2012
    Posts
    24

    Zextras Core Missing after Upgrade to 1.2.5

    Hello,
    here comes the next problem:
    after upgrading to v 1.2.5, Zimbra admin panel is stating zextras core is missing.
    Already tried to uninstall via install.sh -u all and reinstalling without success.

    KR Johannes

  2. #2
    Member
    Join Date
    Jan 2012
    Posts
    24
    I just realize, that there is something of 1.2.5 core still installed:

    :~/zextras_suite-1.2.5# ./install.sh -u all
    -------------------------
    Checking for existing installations ...
    FOUND Zimbra 7.1.4
    -------------------------
    Checking whether the Core is already installed ...
    Checking whether the ZeXtras Suite Zimlet is already installed ...
    Checking whether the ZeXtras Migration Tool Zimlet is already installed ...
    -------------------------
    Detected ZeXtras Suite Core version 1.2.5
    No preexistent ZeXtras Migration Tool Zimlet installation found.
    No preexistent ZeXtras Suite Zimlet installation found.
    -------------------------
    ===========================
    Beginning Core removal procedure ...
    The Zimbra Web Application must be restarted
    in order to perform the installation.
    Do you wish to stop the Zimbra Web Application (mailboxd)? [Y]
    Stopping mailboxd...done.
    ZeXtras Suite Core will be removed. Proceed? [N] y
    Uninstalling ZeXtras Suite Core ...
    ZeXtras Core successfully removed.
    ===========================
    No ZeXtras Suite Zimlet installation has been found to remove. Exiting.
    WARNING: The Zimbra Web Application (mailboxd) is inactive. Restart Manually.
    E.g. su - zimbra -c 'zmmailboxdctl start'
    ~/zextras_suite-1.2.5#

    After running uninstall 3 times, the core seems to be uninstalled.
    But when i install 1.2.5 it states:
    Checking whether the Core is already installed ...
    ZeXtras Suite Core detected.
    Deploying zimlet ...

    And when logging in, i get the error "zextras Core missing"...

  3. #3
    CTO ZeXtras Employee d0s0n's Avatar
    Join Date
    Apr 2011
    Posts
    565
    Hi JoeKar,
    I'm trying to understand your issue because the installer is very simple, to check if the Core is installed you can:

    - list the folder /opt/zimbra/lib/ext/zextras/ where you can find (or not) the zextras.jar file
    - view the /opt/zimbra/log/mailbox.log for initialization logs
    2012-04-01 11:29:47,652 INFO [main] [] extensions - extension com.zextras.extension.ZExtrasExtension found in /opt/zimbra/lib/ext/zextras/zextras.jar
    [...]
    2012-04-01 11:29:48,439 INFO [main] [] extensions - Post-Initializing extensions
    2012-04-01 11:29:48,440 INFO [main] [] extensions - Starting ZeXtras version 1.2.5 commit 4619667f46a2cb3456ffdabb226ee9d092892c48
    2012-04-01 11:29:48,574 INFO [main] [] extensions - license check
    2012-04-01 11:29:49,588 INFO [main] [] extensions - license changed

    or file not found logs:
    2012-04-01 17:20:18,620 WARN [main] [] extensions - no Zimbra-Extension-Class found, ignored: /opt/zimbra/lib/ext/zextras

    When you upgrade ZeXtras Suite you can install the new version without remove the installed one, but when you see in console the message "ZeXtras Core successfully removed." the remove command is successfully ran.

    So to solve your problem I need more info, can you run the installer in debug mode?
    Code:
    bash -x ./install.sh -u all
    and
    Code:
    bash -x ./install.sh all
    Checking every time the /opt/zimbra/lib/ext/zextras/ folder and /opt/zimbra/log/mailbox.log file, I'm very curious...


    D0s0n
    ZeXtras Website # ZeXtras Wiki # ZeXtras Store

    Head of ZeXtras System Administrators

  4. #4
    Member
    Join Date
    Jan 2012
    Posts
    24
    Hello, thanks for your quick reply!

    Actually the folder /opt/zimbra/lib/ext/zextras/ is empty before installing.
    Starting a debug install finishes with:
    + echo 'The ZeXtras Suite Zimlet has been successfully installed.'
    The ZeXtras Suite Zimlet has been successfully installed.

    In /opt/zimbra/lib/ext/zextras/ i have the zextras.jar afterwards.

    Still when logging in to the admin panel i get "ZeXtras Core Missing!"

    I have the complete bash logfile but don't find an option to upload it?

    KR Johannes

  5. #5
    CTO ZeXtras Employee d0s0n's Avatar
    Join Date
    Apr 2011
    Posts
    565
    You can send an email to community@zextras.com, with:

    - Bash log file
    - mailbox log file (Zimbra startup lines)
    - output of this command, as zimbra user:
    Code:
    $zmzimletctl  info com_zextras_zextras
    Zimlet com_zextras_zextras
             Version: 1.2.5
    So I guess your problem is the zimlet version: ZeXtras Core version and zimlet version have to match!

    D0s0n
    ZeXtras Website # ZeXtras Wiki # ZeXtras Store

    Head of ZeXtras System Administrators

  6. #6
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Quote Originally Posted by JoeKar View Post
    Hello, thanks for your quick reply!

    Actually the folder /opt/zimbra/lib/ext/zextras/ is empty before installing.
    Starting a debug install finishes with:
    + echo 'The ZeXtras Suite Zimlet has been successfully installed.'
    The ZeXtras Suite Zimlet has been successfully installed.

    In /opt/zimbra/lib/ext/zextras/ i have the zextras.jar afterwards.

    Still when logging in to the admin panel i get "ZeXtras Core Missing!"

    I have the complete bash logfile but don't find an option to upload it?

    KR Johannes
    Hello Johannes,

    we checked the logs you provided and the installer is working flawlessly, looks like the problem is caused by a problem in the initialization of the ZeXtras Core.
    Can you please search the /opt/zimbra/log/mailbox.log file (of April 1st) and send me any lines related with the mailboxd restart? If such logfile is not available please manually restart the mailboxd service and send me the related logs...

    Regards,
    Cine
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  7. #7
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Hello everybody,

    the issue was caused by a "series of unfortunates events" happened during Zimbra's update procedure...

    Marking as solved!
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •