Broken multiservers after upgrade to 2.6.0
Results 1 to 5 of 5

Thread: Broken multiservers after upgrade to 2.6.0

  1. #1
    Senior Member Known ZeXtras Reseller
    Join Date
    Jul 2011
    Posts
    68

    Broken multiservers after upgrade to 2.6.0

    Hi all.

    Multiservers setup running 8.6.0.P7.
    If was running well with ZeXtras Suite 2.4.0 and I decided to upgrade it to 2.6.0.

    I tried the following on several servers of the multiservers setup, the same problem arises on each.

    Upgrading the core from CLI seems OK.
    No error message.

    However, once upgraded (and before upgrading the zimlets), I wanted to test the admin WebUI.
    It's impossible.

    mailboxd is ok (no error in mailbox.log nor zmmailboxd.out), lsof shows it listens on all ports (110, 443, 7071, etc).
    The daemon accepts the connection (tried on port 443 and 7071) but it doesn't answer to queries.

    I removed the core, tried to set it up again, same issue.

    I eventually downgraded back to 2.4.0 (with zal-1.11.13-8.6.0.jar), this works.

    I did not see anyone with the same issue in the forum.
    Any idea where to dig?

  2. #2
    Zextras employee Known ZeXtras Reseller
    Participant

    Join Date
    Aug 2016
    Posts
    79
    Hi Klug.

    Did you notice any Javascript error browsing the admin console?

    Could I ask you to open a ticket on our support portal, with a brief description of your environment (number of server, OS, etc) and of the upgrade procedure (from which server you started and install parameter (./install.sh or ./install.sh core)?


    Have a nice day,
    Luca
    the Zextras Team
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  3. #3
    Senior Member Known ZeXtras Reseller
    Join Date
    Jul 2011
    Posts
    68
    As I said, I can not access the admin console as the mailboxd is not answering...

    Ticket opened.
    Last edited by Klug; 11-02-2017 at 01:54 PM.

  4. #4
    Junior Member
    Join Date
    Jan 2018
    Posts
    1
    Hi,

    I just Upgrade do ZeXtras Suite 2.6.1, yesterday, the instalation went fine, no errors, i follow all the procedures in the Guide, things look fine.
    But today when i go to the Web Administration Console of Zimbra i receave the massage "ZeXtras core missing..." than i got worried about that message.
    I don't remmember seeing that message during my tests yesterday.
    Than while i was writing this post i go again to the Console to copy the exactly error message and it's gone.
    When the message appears all the buttons in the Core tab were blured, now they ara all fine.

    Should i be concerned about that? That is something instable already reported about this version of ZeXtras Suite?

  5. #5
    Zextras employee Known ZeXtras Reseller
    Participant

    Join Date
    Aug 2016
    Posts
    79
    Hello Rafael,
    and welcome to Zextras Forum!

    As I answered on the support portal, for who will have the same issue, often this error message is related to a low zimbraHttpDosFilterMaxRequestsPerSec.

    The access.log and the mailboxd.out should report some 429 errors:

    Code:
    "https://172.17.0.2:7071/zimbraAdmin/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36" 1
    192.168.1.100 - - [11/Jan/2018:09:53:04 +0000] "POST https://172.17.0.2:7071/service/admin/soap/zextras HTTP/1.1" 429 274 "https://172.17.0.2:7071/zimbraAdmin/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36" 0
    and
    Code:
    2018-01-10 17:04:37.838:WARN:oejs.DoSFilter:qtp1068934215-4008:https:https://172.17.0.2:7071/service/admi...RightsRequest: DOS ALERT: Request rejected ip=192.168.1.100, session=null, user=null
    2018-01-10 17:04:37.840:WARN:oejs.DoSFilter:qtp1068934215-4008:https:https://172.17.0.2:7071/service/admi...etCertRequest: DOS ALERT: Request rejected ip=192.168.1.100, session=null, user=null
    2018-01-10 17:04:37.840:WARN:oejs.DoSFilter:qtp1068934215-3970:https:https://172.17.0.2:7071/service/admi...erversRequest: DOS ALERT: Request rejected ip=192.168.1.100, session=null, user=null

    In this case, we suggest to increment zimbraHttpDosFilterMaxRequestsPerSec

    Code:
    zmprov mcf  zimbraHttpDosFilterMaxRequestsPerSec 200
    zmmailboxdctl restart
    Have a nice day,
    Luca
    The Zextras Team
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •