AccountServiceException: no such zimlet: com_zextras_zextras
Results 1 to 4 of 4

Thread: AccountServiceException: no such zimlet: com_zextras_zextras

  1. #1
    Active Member ZeXtras Reseller
    Join Date
    Jan 2012
    Posts
    6

    AccountServiceException: no such zimlet: com_zextras_zextras

    Error while installing zextras_suite-1.10.3:



    Press ENTER to continue ...

    Deploying zimlet ...

    com.zimbra.cs.account.AccountServiceException: no such zimlet: com_zextras_zextras
    ExceptionId:main:1429020381011:225ef5bf67a76bdd
    Code:account.NO_SUCH_ZIMLET
    at com.zimbra.cs.account.AccountServiceException.NO_S UCH_ZIMLET(AccountServiceException.java:260)
    at com.zimbra.cs.zimlet.ZimletUtil.setPriority(Zimlet Util.java:1135)
    at com.zimbra.cs.zimlet.ZimletUtil.dispatch(ZimletUti l.java:1902)
    at com.zimbra.cs.zimlet.ZimletUtil.main(ZimletUtil.ja va:1973)

    Zimlet installation failed. Exiting.
    .......
    The Zimlet installation has failed. That might be due to an incomplete startup
    of the Zimbra webapp. Please verify Zimbra is up and running, then retry
    the deployment of the zimlet with ./install.sh zimlet .




    # service zimbra status
    Host emailorg.com
    amavis Running
    antispam Running
    antivirus Running
    dnscache Running
    ldap Running
    logger Running
    mailbox Running
    memcached Running
    mta Running
    opendkim Running
    service webapp Running
    snmp Running
    spell Running
    stats Running
    zimbra webapp Running
    zimbraAdmin webapp Running
    zimlet webapp Running
    zmconfigd Running



    uname -a
    Linux 3.16.0-34-generic #47~14.04.1-Ubuntu SMP Fri Apr 10 17:49:16 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux


    Zimbra 8.6.0 GA with zcs-patch-8.6.0_GA_1162 installed.




    Any thoughts?

  2. #2
    CTO ZeXtras Employee d0s0n's Avatar
    Join Date
    Apr 2011
    Posts
    570
    Hi niclab,

    I've seen this exception quite some times, and it's usually related to bad permissions on zimlets' files, so please take a look to these previous threads:


    Have a nice day.
    D0s0n
    ZeXtras Website # ZeXtras Wiki # ZeXtras Store

    Head of ZeXtras System Administrators

  3. #3
    Active Member ZeXtras Reseller
    Join Date
    Jan 2012
    Posts
    6
    Changing permission -R root.zimbra on installation folder took care of the error. Thanks.

  4. #4
    CTO ZeXtras Employee d0s0n's Avatar
    Join Date
    Apr 2011
    Posts
    570
    Sorry but this seems a wrong setting, the threads I gave you suggest to use the zmfixperms command. The permission on zimbra folder is not so simple...

    D0s0n
    ZeXtras Website # ZeXtras Wiki # ZeXtras Store

    Head of ZeXtras System Administrators

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •