Help for a newbie taking over a set-up.
Results 1 to 7 of 7

Thread: Help for a newbie taking over a set-up.

  1. #1
    Active Member
    Join Date
    Mar 2015
    Posts
    3

    Help for a newbie taking over a set-up.

    Hi.

    I have inherited responsibility for an existing setup.

    One step of the usage uses the cli to snapshot the Zimbra data. That line includes 'notifications' followed by an email address. But no notifications arrive.

    The line is:

    /opt/zimbra/bin/zxsuite backup doExport /opt/zimbra/backup/zimbra-backup/export notifications server.admin@dexdyne.com

    I have tried replacing that with a personal email address and confirm nothing arrives. I have used nail to send a test email from the machine and that arrives fine.

    Could anyone advise me whether this is expected behaviour, and if not what I might do to get notified :-)

    David.

  2. #2
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Hello David,
    welcome to the forums!

    This is not the expected behaviour, and there are different possible causes... Can you see the appropriate notifications ("Operation Started" and "Operation Completed") in the "Notifications" tab of the ZeXtras Administration Zimlet? If so, is there any error in the Operation Completed one or in the mailbox.log?

    Have a nice day,
    Cine
    the ZeXtras Team
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  3. #3
    Active Member
    Join Date
    Mar 2015
    Posts
    3
    Thank you for your prompt reply.

    Ah, well the problem here is that this is a headless VM :-(

    The process outputs this to stdout:
    ---------------------------------------------------------------


    operationId 8ef4a01f-f52d-431d-94cf-fb9d88d05c75
    server mail.dexdyne.com

    ---------------------------------------------------------------

    I have a file called backupstat in the target directory containing:

    {"firstZeXtrasBuild":"3827de5c1723f2f75cc22f3f3da4 0ef69a34bb7a",
    "firstZeXtrasVersion":"1.8.5",
    "firstZimbraVersion":"8.0.3",
    "backupPath":"/opt/zimbra/backup/zimbra-backup/export",
    "lastSuccessful":"Success","
    firstScan":1368281071270,
    "lastScan":1425416453291,
    "lastZeXtrasBuild":"b4b4923635e5a2c9cafb18542339fc 8f6b861dc1",
    "lastZeXtrasVersion":"1.8.6",
    "lastZimbraVersion":"8.0.3",
    "numTotalAccounts":"19",
    "numActiveBackuppedAccounts":"19",
    "numZimbraItems":"461288",
    "numBackuppedItems":"461288",
    "numItemsPerSecond":"0"}

    ( formatting added )

    The last line looks a bit suspicious, but if it's an incremental backup system it may be fine.

    I ran the script again this morning and the whole backupstat file remains the same ( though the file date has changed ) - I was sort of expecting it to change every time I ran it.....

    I have peered in mail.log, but I can see no hint in there that the notification email ever went.

    I have checked the return code from zxsuite and it is 'successful'.

    Any more help I can provide to track down the issue?

    David

  4. #4
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Hello David,

    the backupstat file is part of ZxBackup's the RealTime Backup engine while you're running an Export so it's normal for it not to change, just as it's normal for the `zxsuite` command to return a clean exit status even if the operation itself encounters an issue as the command only queues the operation - which is in charge to the ZeXtras Core...

    Instead of the mail.log, I'd suggest to check the mailbox.log: there you'll find any Zimbra and ZeXtras Suite error, along with any error concerning the notification email. Also, you can check the status of the export by running `zxsuite backup monitor [operationID]`...

    Have a nice day,
    Cine
    the ZeXtras Team
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  5. #5
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Hello David!

    I'd like to give you a couple more pointers

    - I noticed you are running a VERY old ZeXtras Suite version, please update as soon as possible.
    - I know that this is your first time using ZeXtras Suite, but starting the right way is for sure the best start: the "Export" feature you mentioned is designed for migrations, not for everyday backups - there are better options for that. ZeXtras Backup features a RealTime Backup engine, which I suggest you to enable, and should you need an offsite copy of your backup an rsync of the backup path is easier to do and to manage...

    You can find all ZeXtras Suite's technical docs at ZeXtras Suite Wiki, and as usual feel free to ask any question!

    Have a nice day,
    Cine
    the ZeXtras Team
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  6. #6
    Active Member
    Join Date
    Mar 2015
    Posts
    3
    I thought I'd typed a reply here but it seems to have gone missing.

    I have achieved my practical goal with liberal use of getAllOperations and monitor.

    I'm just propping up what the last guy left me :-)
    I note your helpful suggestions, and have put it on my work-list :-)

    In the meantime, if there is anything you would like me to try to see if we can pin down th reason for the lack of notifications, do tell me.

    Or are you saying the notifications stuff is done by the s/w I should be updating, and so tracking-down bugs in it is not a useful way to spend our time?

    D.

  7. #7
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Hello Dexdyne!

    There's for sure a chance that the issue is caused by a ZeXtras Suite bug we didn't catch at the time, so the first step would be to upgrade: it's not a matter of useful ways to spend time - helping users is always useful - but I'd like to rule out the "old bug" possibility from the list as soon as possible

    Other than this, I'd like you to check the lines in the mailbox.log around the time the operation was completed - this is the best way to find any notification-related error...

    About the taking the job over from the guy before you: don't worry, feel free to ask anything that comes into your mind! No question is "stupid" or "useless" here, and I'll be more than glad to give you all the pointers you need...

    Have a nice day,
    Cine
    the ZeXtras Team
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •