zimbra "system failure: exception during auth" error
Results 1 to 7 of 7
Like Tree2Likes
  • 1 Post By d0s0n
  • 1 Post By anandi

Thread: zimbra "system failure: exception during auth" error

  1. #1
    Member ZeXtras Reseller
    Participant

    Join Date
    Nov 2012
    Posts
    47

    zimbra "system failure: exception during auth" error

    Just started to see this error:

    Server error encountered
    Message: system failure: exception during auth {RemoteManager: zimbraxxxx.domain.net->zimbra@zimbraxxxx.domain.net:22} Error code: service.FAILURE Details:soap:Receiver



    Any ideas what can cause this ?

  2. #2
    Member ZeXtras Reseller
    Participant

    Join Date
    Nov 2012
    Posts
    47
    Ok found this is to do with the ssh port. I have changed ssh port from 22 to 22222. Need to figure out how to convey it to zimbra

  3. #3
    Member ZeXtras Reseller
    Participant

    Join Date
    Nov 2012
    Posts
    47
    Can't seem to fix this. I changed ssh port to 2222 before zimbra install and everything is fine. Now i am getting the above soap error on a single page. I found that zimbra does an internal ssh to the hostname to check for status. Now somewhere its stuck at port 22 and somewhere its using 2222 (because if i change the server ssh port to 22, all zimbra services shutdown)

    Any ideas on how to fix this ?

    Thanks

  4. #4
    CTO ZeXtras Employee d0s0n's Avatar
    Join Date
    Apr 2011
    Posts
    565
    Quote Originally Posted by anandi View Post
    ...Now somewhere its stuck at port 22 and somewhere its using 2222 (because if i change the server ssh port to 22, all zimbra services shutdown)
    Hi anandi,
    Zimbra needs to make some commands using ssh, the default port is 22. If you need to change that port take a look at zimbraRemoteManagementPort zimbra property:
    Code:
    <attr id="339" name="zimbraRemoteManagementPort" type="integer" cardinality="single" optionalIn="globalConfig,server" flags="serverInherited" callback="CheckPortConflict" requiresRestart="mailbox">
      <globalConfigValue>22</globalConfigValue>
      <desc>Port on which remote management sshd listening on this server.</desc>
    </attr>
    D0s0n
    ZeXtras Website # ZeXtras Wiki # ZeXtras Store

    Head of ZeXtras System Administrators

  5. #5
    Member ZeXtras Reseller
    Participant

    Join Date
    Nov 2012
    Posts
    47
    Hi D0s0n,

    I know its the zimbraRemoteManagementPort setting and i found the below command for the same as well:

    zmprov ms zimbra102.domain.net zimbraRemoteManagementPort 22222


    However when i check the value inside zimbra

    zmprov gacf | grep Remote
    zimbraRemoteManagementCommand: /opt/zimbra/libexec/zmrcd
    zimbraRemoteManagementPort: 22
    zimbraRemoteManagementPrivateKeyPath: /opt/zimbra/.ssh/zimbra_identity
    zimbraRemoteManagementUser: zimbra

    Seems like whatever i do, its ignoring the value given on the command line. Is there a property file which i can change and probably restart zimbra to take the new values ?

    Thanks for the help.

  6. #6
    CTO ZeXtras Employee d0s0n's Avatar
    Join Date
    Apr 2011
    Posts
    565
    Quote Originally Posted by anandi View Post
    Hi D0s0n,

    I know its the zimbraRemoteManagementPort setting and i found the below command for the same as well:

    zmprov ms zimbra102.domain.net zimbraRemoteManagementPort 22222
    This command set the property at server level.

    Quote Originally Posted by anandi View Post
    However when i check the value inside zimbra

    zmprov gacf | grep Remote
    zimbraRemoteManagementCommand: /opt/zimbra/libexec/zmrcd
    zimbraRemoteManagementPort: 22
    zimbraRemoteManagementPrivateKeyPath: /opt/zimbra/.ssh/zimbra_identity
    zimbraRemoteManagementUser: zimbra

    Seems like whatever i do, its ignoring the value given on the command line. Is there a property file which i can change and probably restart zimbra to take the new values ?
    ...and with "gacf" command you are asking for the property value at global level, so you need to set the property with this command:
    Code:
    zmprov mcf zimbraRemoteManagementPort 22222
    D0s0n
    anandi likes this.
    ZeXtras Website # ZeXtras Wiki # ZeXtras Store

    Head of ZeXtras System Administrators

  7. #7
    Member ZeXtras Reseller
    Participant

    Join Date
    Nov 2012
    Posts
    47
    Quote Originally Posted by d0s0n View Post
    This command set the property at server level.



    ...and with "gacf" command you are asking for the property value at global level, so you need to set the property with this command:
    Code:
    zmprov mcf zimbraRemoteManagementPort 22222
    D0s0n
    You are a life saver This changed the port, testing now the interface for errors.

    Thanks a ton.
    d0s0n likes this.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •