ZeXtras Suite 1.9.x: Information and Feedback
Page 1 of 9 123 ... LastLast
Results 1 to 10 of 89
Like Tree1Likes

Thread: ZeXtras Suite 1.9.x: Information and Feedback

  1. #1
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342

    ZeXtras Suite 1.9.x: Information and Feedback

    Hello everybody!

    I'm glad to announce that ZeXtras Suite 1.9.4 has been released!
    Please take your time to have a look at the Official Announcement thread about this topic to see what's going on, it'll provide you with an overview of what ZeXtras Suite 1.9.x is and why it's a very importany milestone

    This post is meant to be a haven for all ZeXtras Suite 1.9.x testers, in which you can report issues and discuss this new release.

    As with any release, I prepared a small Changelog containing all the changes and fixes in relation to both the alpha package released on September 5th and to the latest stable release (1.8.18).

    DOWNLOAD LINKS
    The download link can be found in the "Download" page of the ZeXtras Website.
    The ZeXtras Migration Tool can be downloaded from HERE.

    USEFUL INFORMATION
    • ZeXtras Suite 1.9.x is BETA software and it's not meant for production use.
    • ZeXtras Suite 1.9.x comes with a special fully featured "Testing" license which is set to expire on November 6th.
    • Please, don't open support tickets for any issue related to ZeXtras Suite 1.9.x.
    • Always remember to follow the "How to Report a ZeXtras Suite issue" guide when reporting an issue.
    • Any logfile can be sent to community@zextras.com: please include the specific post link related to your report in the subject. Any other kind of email or request to this address will not be take in charge.


    CHANGELOG
    1.9.4

    • Fixed a critical issue affecting the ZeXtras Powerstore module which could cause data loss of items moved by the HSM engine. More info about how to fix any item lost because of this bug HERE.
    • Since the ZAL component has been updated, ZAL 1.4 is the minimum requirement to run ZeXtras Suite 1.9.4. The installer will autonomously download and install the new component
    • ZeXtras Suite 1.9.4 can be installed on any Zimbra version equal or higher than 6.0.7.
    • Fixed a bug that caused the "doMakeBuddies" feature not to properly complete the buddylist add.
    • Fixed a bug that caused ZeXtras Backup to return a "Case Insensitive filesystem" error in case of bad r/w permissions on the Backup Path.
    • The "Purge" operation of ZeXtras Backup has been heavily optimized, thus decreasing the average running time.



    1.9.3

    • All bugfixes released in ZeXtras Suite 1.8.18 have been ported to the 1.9.x tree.
    • Fixed a bug that could cause "Invalid Metadata" errors when importing data from Zimbra 8.0.x to 8.5.x.
    • Fixed a bug that could cause a blocking "NullPointer Exception" error when running a BLOB Move.



    1.9.2


    • Starting from this version, the 1.9.x branch can be installed on Zimbra NE.
    • Starting from this version, the ZeXtras Migration Tool will be released together with ZeXtras Suite in the 1.9.x branch.
    • Fixed a bug that could cause Meeting Invitations not to be properly sent when using Outlook 2013.
    • Fixed a bug that could cause "NumberFormatException: For input string: "XA0" " ZxMobile errors.
    • Fixed a bug that could cause Meeting Invitations to be sent without proper default data causing an "internal server error".
    • Fixed a bug that would cause the ZeXtras Installer to fail on older bash versions (3.2 and older reported failing)



    1.9.1

    • Since the ZAL component has been updated, ZAL 1.2 is the minimum requirement to run ZeXtras Suite 1.9.1. The installer will autonomously download and install the new component.
    • Fixed many ZxBackup bugs, most of which affected the External Restore feature.
    • Minor code cleanups in all modules to further reduce the chances of NullPointer exceptions.



    1.9.0

    • Since the ZAL component has been updated, ZAL 1.1 is the minimum requirement to run ZeXtras Suite 1.9.0. The installer will autonomously download and install the new component.
    • Fixed a bug that could cause emails sent via ZeXtras Mobile to "vanish" without being delivered.
    • Fixed an UI bug that caused a wrong "Mobile Device Management not enabled" warning in the ZeXtras Administration Zimlet.
    • Fixed an issue in the ZeXtras Installer that caused a "zxtools --set-mode failed" error.
    • Fixed a bug that could cause the upload of a new license to fail if done through the ZeXtras Administration Zimlet.
    • Fixed several minor ZxMobile issues related to nonexisting folders, calendar, task and contact sync (NullPointer exception and Runtime Errors).


    KNOWN ISSUES

    • In Multiserver infrastructures the following message will be displayed during the Zimlet installation:

    Code:
    INFO: Deploying on ui node master.example.com
    INFO: deploy failed on ui node master.example.com
    
    
    The zimlet installation might have failed, please check whether
    the ZeXtras Administration Zimlet is properly displayed
    upon accessing the Zimbra Administration Console.
    
    Installation failure might be caused by an incomplete startup
    of the Zimbra "mailboxd" service or by a server configuration issue.
    
    Please verify that Zimbra is up and running, then retry the deployment
    of the zimlet running « ./install.sh zimlet ».
    
    Check
    /tmp/zextras-zimlet-install-log-XYX.txt
    for further details.
    This seems to be caused by a "zmzimletctl" issue beyonf our control, so please log into the Zimbra Administration Console and check whether the ZeXtras Administration Zimlet has been correctly installed before reporting an issue.


    • The Zimbra Web Client's new "Offline" feature is currently causing some usage issues to ZeXtras Chat Zimlet users after a zimlet update: at the moment, the only workaround is to temporarily disable the "Offline" feature, reload the Zimbra Web Client and re-enable the "Offline" feature each time a new version of the ZeXtras Chat Zimlet has been deployed.


    BONUS: ZIMBRA 8.5.0 KNOWN ISSUES
    There's a handy list of Zimbra 8.5.0 known issues on the Zimbra Wiki, which I strongly suggest to have a look at when testing/deploying this new Zimbra version.
    You can find it at
    https://wiki.zimbra.com/wiki/Current_issues_in_ZCS_8.5



    Enjoy!
    Last edited by Cine; 10-10-2014 at 04:48 PM.
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  2. #2
    Active Member
    Join Date
    Sep 2014
    Posts
    3

    Help: Installation error zextras 1.9.0

    Installing zimlet, returns the following error:

    [] INFO: Deploying Zimlet com_zextras_zextras in LDAP.
    [] INFO: Installing Zimlet com_zextras_zextras on this host.
    [] INFO: Deploying on ui node ldap01.xxxxx.com
    [] INFO: deploy failed on ui node ldap01.xxxxx.com

    The zimlet installation might have failed, please check whether
    the ZeXtras Administration Zimlet is properly displayed
    upon accessing the Zimbra Administration Console.

    Installation failure might be caused by an incomplete startup
    of the Zimbra "mailboxd" service or by a server configuration issue.

    Please verify that Zimbra is up and running, then retry the deployment
    of the zimlet running « ./install.sh zimlet ».

    The installation log file is detailed below:

    com.zimbra.common.service.ServiceException: invalid request: server ldap01.xxxxx.com does not have zimbraMailMode set, maybe it is not a store server?
    ExceptionId:main:1410382248191:cd8cb55c4cfce4a9

    The environment where you are installing the zimlet is a Multiserver (02 LDAP Server, 01 MTA Server, 01 Mailbox Server)

    Thanks for the support
    Last edited by rquezada; 09-10-2014 at 09:53 PM.

  3. #3
    Member
    Join Date
    Jun 2014
    Posts
    29
    Quote Originally Posted by Cine View Post
    KNOWN ISSUES

    • The "External Restore" restore mode is not yet perfectly functional - it might fail due to a Null Pointer Exception error or silently fail to start.

    Is there any idea on when the External Restore option might be fixed? This is what I'm trying to test with 1.9.

    Thx!

  4. #4
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Hello bjquinn!

    We tracked down a couple of very pesky issues, on which we are working on, but we currently couldn't manage to reproduce the issue you reported in the alpha-related thread.
    Will get back to you as soon as I have any news from the devs
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  5. #5
    Active Member
    Join Date
    Sep 2014
    Posts
    4
    The new Beta release installs now flawless - thanks.

    Restore of an email account for me did not work, as I have my old server using the ZimbraPosixAccount Zimlet.
    My question: Do I just need to install the ZimbraPosixAccount Zimlet on Zimbra v8.5? I don't intend to use that Zimlet no more in the future.
    Any other way to make it work?

    Thanks, William

  6. #6
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Hello rquezada!

    We are currently aware of the issue you report about multiserver installs, and the cause seems to be the "zmzimletctl" Zimbra command used to deploy the ZeXtras Administration Zimlet which causes the "does not have zimbraMailMode set" error during installation because of a bad server role response.

    Did you manually check whether the ZeXtras Administration Zimlet was successful or not as described in the error message?

    Have a nice day,
    Cine
    the ZeXtras Team
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  7. #7
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Quote Originally Posted by ITGuy View Post
    The new Beta release installs now flawless - thanks.

    Restore of an email account for me did not work, as I have my old server using the ZimbraPosixAccount Zimlet.
    My question: Do I just need to install the ZimbraPosixAccount Zimlet on Zimbra v8.5? I don't intend to use that Zimlet no more in the future.
    Any other way to make it work?

    Thanks, William
    Hello William!

    I need to furher investigate the issue, could you please send me the mailbox.log pertinent to the day the restore was ran and the "account_info" file for the affected account?
    You can find the account_info file in
    Code:
    [import path]/accounts/[account ID]/account_info
    Have a nice day,
    Cine
    the ZeXtras Team
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

  8. #8
    Active Member
    Join Date
    Sep 2014
    Posts
    3
    I tried manually installing the zimlet cli and web console but always returns the same error. So what I did was run the zmtlsctl command on all servers that have the attribute zimbraMailMode because after this step the installation but at the time of deploying the chat zimlet reported several warning.

    But in the end the zimlet was installed but checking can not send messages.

  9. #9
    Active Member
    Join Date
    Sep 2014
    Posts
    4
    Thank you Cine.

    I have emailed the required info to (community@zextras.com).

    I appreciate your help.

    Regards, William

  10. #10
    ZeXtras Community Manager ZeXtras Employee Cine's Avatar
    Join Date
    Apr 2011
    Posts
    2,342
    Quote Originally Posted by ITGuy View Post
    Thank you Cine.

    I have emailed the required info to (community@zextras.com).

    I appreciate your help.

    Regards, William
    Great!
    Will report back ASAP

    Have a nice day,
    Cine
    the ZeXtras Team
    IT Support Team Contact Form
    Sales Team Contact Form

    ZeXtras Website
    # ZeXtras Wiki # ZeXtras Store

    Have ZeXtras Suite or ZeXtras Migration Tool been helpful to you?
    Share your experience in the Zimbra Gallery!

    ZeXtras Suite on the Zimbra Gallery
    ZeXtras Migration Tool on the Zimbra Gallery

Page 1 of 9 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •